Prerequisites

www.altova.com Print this Topic Previous Page Up One Level Next page

Home >  ActiveX Integration >

Prerequisites

To integrate the MapForce ActiveX control into a custom application, the following must be installed on your computer:

 

MapForce
The MapForce Integration Package, available for download at https://www.altova.com/components/download

 

To integrate the 64-bit ActiveX control, install the 64-bit versions of MapForce and MapForce Integration Package. For applications developed under Microsoft .NET platform with Visual Studio, both the 32-bit and 64-bit versions of MapForce and MapForce Integration Package must be installed, as explained below.

 

Microsoft .NET (C#, VB.NET) with Visual Studio

To integrate the MapForce ActiveX control into a 32-bit application developed under Microsoft .NET, the following must be installed on your computer:

 

Microsoft .NET Framework 4.0 or later
Visual Studio 2010/2012/2013/2015/2017
MapForce 32-bit and MapForce Integration Package 32-bit
The ActiveX controls must be added to the Visual Studio toolbox (see Adding the ActiveX Controls to the Toolbox).

 

If you want to integrate the 64-bit ActiveX control, the following prerequisites apply in addition to the ones above:

 

MapForce 32-bit and MapForce Integration Package 32-bit must still be installed (this is required to provide the 32-bit ActiveX control to the Visual Studio designer, since Visual Studio runs on 32-bit)
MapForce 64-bit and MapForce Integration Package 64-bit must be installed (provides the actual 64-bit ActiveX control to your custom application at runtime)
In Visual Studio, create a 64-bit build configuration and build your application using this configuration. For an example, see Running the Sample C# Solution.

 

Java

To integrate the MapForce ActiveX control into Java application using the Eclipse development environment, the following must be installed on your computer:

 

Java Runtime Environment (JRE) or Java Development Kit (JDK) 7 or later
Eclipse
MapForce and MapForce Integration Package

 

Note:To run the 64-bit version of the MapForce ActiveX control, use a 64-bit version of Eclipse, as well as the 64-bit version of MapForce and the MapForce Integration Package.

 

MapForce integration and deployment on client computers

If you create a .NET application and intend to distribute it to other clients, you will need to install the following on the client computer(s):

 

MapForce
The MapForce Integration Package
The custom integration code or application.

© 2019 Altova GmbH