Please enable JavaScript to view this site.

Altova XMLSpy 2022 Professional Edition

Browser View is typically used to view:

 

XML files that have an associated XSLT file. When you switch to Browser View, the XML file is transformed on the fly using the associated XSLT stylesheet and the result is displayed directly in Browser View.

HTML files which are either created directly as HTML or created via an XSLT transformation of an XML file.

 

To view XML and HTML files in Browser View, click the Browser tab.

 

Note about Microsoft Internet Explorer and XSLT

Browser View requires Microsoft's Internet Explorer 5.0 or later. If you wish to use Browser View for viewing XML files transformed by an XSLT stylesheet, we strongly recommend Internet Explorer 6.0 or later, which uses MSXML 3.0, an XML parser that fully supports the XSLT 1.0 standard. You might also wish to install MSXML 4.0. (Note that support for XSLT in IE 5 is not 100% compatible with the official XSLT Recommendation. So if you encounter problems in Browser View with IE 5, you should upgrade to IE 6 or later.) You should also check the support for XSLT of your version of Internet Explorer.

 

Browser View features

The following features are available in Browser View. They can be accessed via the Browser menu, File menu, and Edit menu.

 

Open in separate window: When Browser View is a separate window, it can be positioned side-by-side with an editing view of the same document. To do this, click the menu command Browser | Separate Window. This is a toggle command that switches Browser View between two windows: (i) a separate window, and (ii) a tabbed view in the Main Window. These commands are also available in the dropdown menu of the Browser View button (at the bottom of the Main Window). In the View tab of the Options dialog, you can set whether Browser View should be shown by default in a separate window.

Forward and Back: The common browser commands to navigate through pages that were loaded in Browser View. These commands are in the Browser menu.

Font size: Can be adjusted via the Browser menu.

Stop, Refresh, Print: More standard browser commands, these can be found in the Browser and File menus.

Find: Enables searches for text strings. This command is in the Edit menu.

 

 

© 2016-2022 Altova GmbH