Altova MapForce 2027 Professional Edition

Configurar la compilación y generación automáticas de código de MapForce

Inicio Anterior Inicio Siguiente

La compilación y generación automáticas de código de MapForce está habilitada por defecto en todos los proyectos MapForce/Eclipse (véase Crear un proyecto MapForce/Eclipse). Si desea habilitar la compilación y generación automáticas de código de MapForce en un proyecto existente que no sea de tipo MapForce/Eclipse, puede hacerlo añadiendo manualmente a dicho proyecto el generador Generación de código de MapForce y la naturaleza MapForce.

 

Para agregar el generador Generación de código de MapForce a un proyecto:

 

•Añada al archivo .project de Eclipse las líneas de código que aparecen resaltada a continuación:

 

<buildSpec>
    <buildCommand>
        <name>org.eclipse.jdt.core.javabuilder</name>
        <arguments>
        </arguments>
    </buildCommand>
     <buildCommand>
         <name>com.altova.mapforceeclipseplugin.MapForceBuilder</name>
         <arguments>
         </arguments>
      </buildCommand>
  </buildSpec>

 

Para agregar la naturaleza MapForce a un proyecto:

 

•Añada al archivo .project de Eclipse las líneas de código que aparecen resaltada a continuación:

 

  <natures>
    <nature>org.eclipse.jdt.core.javanature</nature>
     <nature>com.altova.mapforceeclipseplugin.MapForceNature</nature>      
  </natures>

 

Consejo: puede abrir el archivo .project rápidamente desde la vista de navegación Navigator de Eclipse (para habilitar esta vista haga clic en el comando de menú Window | Show View | Navigator).

 

Para activar / desactivar la generación automática de código de MapForce:

 

•En el menú Project haga clic en el comando Build automatically.

 

Para deshabilitar el generador Generación de código de MapForce:

 

1.En el menú Project haga clic en Properties.

2.Después haga clic en Builders.

mf_eclipse_disable_mf_builder

3.Desactive la casilla Generación de código de MapForce.

© 2020-2026 Altova GmbH