Configuración y personalización
En XMLSpy hay varias opciones de configuración y personalización entre los que puede elegir. En esta sección, le indicamos estas opciones y, además, comentamos brevemente algunos aspectos de los menús de XMLSpy. Esta sección se organiza en varias partes:
Opciones de configuración
El cuadro de diálogo Opciones incluye varias pestañas donde se definen importantes opciones de configuración de XMLSpy (imagen siguiente, se accede con el comando Herramientas | Opciones). Le recomendamos que examine las distintas opciones para familiarizarse con todos los ajustes disponibles.

A continuación ofrecemos un resumen de las opciones de configuración más importantes. Para obtener más información, consulte la descripción del cuadro de diálogo Opciones en la sección Referencia del usuario.
•Tipos de archivo y vistas predeterminadas: En la pestaña Tipos de archivo, puede añadir los tipos de archivo que XMLSpy reconocerá. Los tipos de archivo se especifican con una extensión de archivo. Para cada tipo de archivo, podrá especificar a continuación la conformidad con un estándar concreto (por ejemplo, la conformidad con el estándar DTD, XQuery o JSON). Esta configuración activará los ayudantes de entrada correspondientes al estándar seleccionado para un tipo de archivo concreto. También puede especificar en qué vista de XMLSpy deben abrirse los archivos de cada tipo (la vista predeterminada para ese tipo de archivo).
•Validación de archivos: En la pestaña Archivo (imagen anterior), puede especificar si los archivos deben validarse automáticamente al abrirse y/o al guardarse. En la pestaña Tipos de archivo (véase el punto anterior), se puede desactivar la validación de archivos para determinados tipos de archivo.
•Edición: En la pestaña Edición, puede especificar cómo deben organizarse los ayudantes de entrada:, cómo se generan los nuevos elementos y si se activa la función de finalización automática. También encontrará opciones propias de cada vista en la pestaña Vista. En las pestaña Fuentes puede configurar el aspecto de cada tipo de componente de texto en todas las vistas de la aplicación.
•Motores XSLT y FO: En la pestaña XSL, puede especificar que se utilice un motor XSL externo para las transformaciones realizadas desde la interfaz gráfica de usuario. También deberá indicar la ubicación del ejecutable del procesador FO que se debe utilizar para procesar ficheros FO dentro de XMLSpy. Para más información, consulte la sección Procesamiento XSLT.
•Codificación: Las codificaciones predeterminadas para los archivos XML y los que no son XML se especifican en la pestaña Codificación.
Personalización
También puede personalizar varios aspectos de XMLSpy, incluido el aspecto de la IGU. Estas opciones de personalización están disponibles en el cuadro de diálogo Personalizar (imagen siguiente, se accede con el comando de menú Herramientas | Personalizar).

Para ver una descripción más detallada de las opciones de personalización, consulte la sección Referencia del usuario.
Menús
Los diferentes comandos de menú están habilitados o deshabilitados dependiendo de tres factores: (i) el tipo de archivo, (ii) la vista activa y (iii) la posición del cursor o el estado del documento. Por ejemplo:
•Tipo de archivo: El comando DTD/Esquema | Incluir otra DTD solo está disponible cuando el archivo activo es una DTD. Del mismo modo, los comandos del menú WSDL solo estarán disponibles cuando haya un archivo WSDL activo.
•Vista Activa: La mayoría de los comandos del menú Diseño de esquemas solo estarán activos cuando la vista activa sea la Vista Esquema.
•Ubicación actual del cursor, estado del documento: En la vista Cuadrícula, el hecho de que el comando para añadir un atributo como nodo secundario (XML | Agregar secundario | Atributo) esté habilitado dependerá de si el elemento seleccionado en la vista Cuadrícula es un elemento o no (posición actual del cursor). Si está activo un documento XSLT, el comando Detener el depurador solo se activará una vez iniciada la sesión del depurador (estado actual del documento).
Recuerde que también puede personalizar los menús (Herramientas | Personalizar), así como arrastrarlos y reorganizarlos en la IGU (consulte la sección Barra de menú, barras de herramientas y barra de estado).