Aktivieren Sie bitte JavaScript, um diese Seite anzeigen zu können.

Altova DatabaseSpy 2021 Professional Edition

» Keine übergeordneten Kapitel «

Importieren von Datenbankdaten

Bildlauf Zur Startseite Zurück Nach oben Weiter Mehr

Sie können mit DatabaseSpy Daten aus XML- oder CSV-Dateien in Ihre Datenbanken importieren. Wenn Sie in der Extras-Symbolleiste auf die Schaltfläche Importieren ic_import klicken oder die Menüoption Extras | Datenbankdaten importieren... (Strg+I) auswählen, wird das Dialogfeld Daten in die Datenbank importieren geöffnet, in dem Sie die gewünschte XML- oder CSV-Datei auswählen und die Importoptionen definieren können. Das Dialogfeld Daten in die Datenbank importieren enthält zwei Register, nämlich das Register "Auswahl" und das Register "Optionen".

 

dlg_import-selection

 

Der untere Teil des Dialogfelds zeigt eine Vorschau der ausgewählten Daten. Diese Vorschau kann aktualisiert werden, um die Auswirkung der gewählten Optionen wiederzugeben.

 

imp-csv2

 

Sie können wählen, ob Sie eine Vorschau der Daten (obige Abbildung) oder  der Definition (unten stehende Abbildung) der Tabellenstruktur des gewählten Elements anzeigen wollen.

 

imp-csv3

 

Alle Felder werden als Textfelder mit der im Register "Optionen" festgelegten Länge erstellt. Sie können im Vorschaugruppenfeld den Datentyp separat für jede Spalte ändern, wenn sie die Optionsschaltfläche Definition anzeigen auswählen (siehe oben stehende Abbildung).

So importieren Sie Daten aus einer CSV- oder Textdatei in eine Datenbank:

1.Stellen Sie sicher, dass eine Datenquelle im Projektordner aktiv ist.

2.Wählen Sie die Menüoption Extras | Daten in die Datenbank importieren oder drücken Sie Strg+I oder klicken Sie in der Extras-Symbolleiste auf die Schaltfläche Importieren ic_import.Daraufhin wird das Dialogfeld Daten in die Datenbank importieren geöffnet.

3.Klicken Sie links oben im Dialogfeld je nach Bedarf entweder auf die Schaltfläche XML oder CSV.

4.Geben Sie im Textfeld Pfad den Pfad zur gewünschten Textdatei ein.

Sie können den Pfad eingeben, die Datei aus der Dropdown-Liste auswählen oder auf die Schaltfläche Durchsuchen ic_browse klicken.

5.Füllen Sie unter "Ziel" je nach Bedarf die Zieldatenquelle, -datenbank und das Zielschema aus. Wenn Sie zuvor bereits eine Datenquelle ausgewählt haben, werden die drei Felder automatisch ausgefüllt. Falls nicht, gehen Sie folgendermaßen vor:

 

a)Wählen Sie die Datenquelle, die Datenbank und das Schema aus den Dropdown-Listen aus.

b)Wählen Sie, je nachdem wohin die Daten importiert werden sollen, eine der Optionen Neue Tabelle(n) erstellen,  Aktualisieren/Erstellen, falls nicht vorhanden, oder Vorhandene Tabellen aktualisieren.

c)Definieren Sie in der Dropdown-Liste Nach Fehlern anhalten die Anzahl der Fehler, nach denen der Import gestoppt werden soll.

d)Wählen Sie in der Dropdown-Liste Stopp-Aktion die Aktion aus, die durchgeführt werden soll, wenn der Import gestoppt wird: Mit Commit werden die Tabellen übernommen, die keine Fehler enthalten haben; mit rollback werden keine der importierten Daten übernommen.

 

6.Wählen Sie in der Gruppe "Importmodus" eine oder mehrere der folgenden Optionen aus:

 

Aktivieren Sie die Option Ausführen, wenn die erforderliche SQL-Datei auf einmal generiert und ausgeführt werden soll.

Aktivieren Sie die Option SQL in SQL Editor generieren, wenn die generierte SQL-Datei ausführungsbereit in den SQL Editor platziert werden soll.

Aktivieren Sie das Kontrollkästchen Log, um die Dropdown-Liste zu aktivieren, in der Sie den Namen und Pfad für die SQL-Log-Datei angeben können. Über die Schaltfläche Durchsuchen können Sie eine zuvor verwendete Log-Datei oder eine vorhandene Log-Datei auswählen.

 

7.Klicken Sie auf die Schaltfläche Neu laden, um eine Vorschau der Daten anzuzeigen und die Einstellungen näher zu definieren. Wenn Sie eine der vorherigen Optionen aktiviert haben, müssen Sie diese Schaltfläche eventuell verwenden.

8.Klicken Sie optional in die Spalte "Target Table Name", um den Zielspaltennamen zu ändern.

9.Klicken Sie auf das Optionsfeld Daten anzeigen oder Definition anzeigen, um die verschiedenen Aspekte der Tabellenstruktur zu bearbeiten.

10.Doppelklicken Sie auf ein Feld im Vorschaufenster, um den Datentyp, die Zulässigkeit von NULL-Werten oder die Indizierung zu bearbeiten.

Definieren Sie, ob und wie die einzelnen Spalten importiert werden sollen. Klicken Sie dazu auf die Spaltenüberschrift, um die Einstellung zu ändern.

 

ic_include-col Importieren
ic_unique-key Als eindeutigen Schlüssel importieren
ic_primary-key Als Primärschlüssel importieren
ic_exclude-col Nicht importieren

 

11.Wählen Sie eine der folgenden Methoden:

 

Wenn zuvor die Option Ausführen aktiviert wurde, klicken Sie auf Importieren. Daraufhin wird die Textdatei in die Datenbank importiert und es erscheint eine Meldung, in der Sie gefragt werden, ob Sie log.sql-Datei anzeigen möchten.

Wenn zuvor die Option SQL in SQL Editor generieren aktiviert war, klicken Sie auf SQL generieren. In diesem Fall müssen Sie zuerst das generierte SQL-Script ausführen, um die Textdatei in die Datenbank zu importieren, siehe Ausführen von SQL-Anweisungen.

© 2015-2021 Altova GmbH