Download European Banking Authority (EBA) XBRL Add-in for Excel

The Altova European Banking Authority (EBA) XBRL add-in for Excel makes it easy to generate valid EBA XBRL in the familiar Excel environment.

Select your software version, and click the Download button below to download the self- contained Installer for the add-in.

Note: please download the OS version that corresponds to your Excel installation (32- or 64-bit).

Altova European Banking Authority (EBA) XBRL add-in for Excel - Enterprise Edition

enables you to use an intelligent template in Excel to build valid EBA XBRL reports quickly and easily. Enterprise Edition also includes batch EBA XBRL to Excel conversion and an API for batch conversion.

Start a FREE 30-day trial or activate with your purchased license

Altova European Banking Authority (EBA) XBRL add-in for Excel - Basic Edition

enables you to use an intelligent template in Excel to build valid EBA XBRL reports quickly and easily.

Start a FREE 30-day trial or activate with your purchased license

XBRL Taxonomies

To assist customers working with the ever-increasing volume of XBRL taxonomies and frequent updates, the Altova European Banking Authority (EBA) XBRL add-in for Excel includes a convenient XBRL Taxonomy Manager that provides a centralized way to install and manage XBRL taxonomies for use across all Altova XBRL-enabled applications.

The XBRL Taxonomy Manager will launch when you open an XBRL document for which the taxonomy is not installed, and you can also access the XBRL Taxonomy Manager from the Tools menu.

Alternatively, if you are working within a secure network and need to manually download taxonomies, you may access them here.

Note: If you have a version prior to v2021 of the EBA Add-in for Excel, please use this page to install additional XBRL Taxonomies.

Free Trial Evaluation Information

To start your free, 30-day trial, simply download and install the software. When you start the software, you will be prompted to request a license, which you will receive via email.

Please note: The add-in requires Excel 2010, 2013 or 2016. It is not compatible with prior versions.