IMPORTANT:
this is not a Support Forum! Experienced users might answer from time to time questions posted here. If you need a professional and reliable answer, or if you want to report a bug, please contact Altova Support instead.

Profile: Pawel
About
User Name: Pawel
Forum Rank: Newbie
Real Name: Pawel
Location Poland
Occupation:
Interests:
Gender: Male
Statistics
Joined: Wednesday, October 30, 2019
Last Visit: Saturday, November 23, 2019 6:01:49 AM
Number of Posts: 7
[0.04% of all post / 0.16 posts per day]
Avatar
Last 10 Posts
Topic: REST API -URL forbidden characters
Posted: Tuesday, November 19, 2019 8:28:56 PM
Hello That,

Thank You for your help again, once I have changed the name of the parameter to "bank_accounts" everything started to work nicely.

I appreciate you support me in my Map Force beggining steps.

Pawel.
Topic: REST API -URL forbidden characters
Posted: Tuesday, November 19, 2019 12:39:37 PM
Hello all,

Just a thought. Should I report above case as a bug or support ticket to Altova?

I will wait couple more days to see if any answer appears and them I will probbably do it.

Pawel
Topic: Mapping json array to text file
Posted: Monday, November 18, 2019 10:08:00 PM
Hello,

Thank you for your reply. I have connected strings from "accountNumbers" array to the Rows node of output txt file and at the same time to "accountNumbers" data node. It works now how I intended.
Topic: REST API -URL forbidden characters
Posted: Monday, November 18, 2019 6:32:51 AM
Hello,

I have to incorporate a below URL into Web service call settings in mapforce

https://wl-api.mf.gov.pl/api/search/bank-accounts/{bank-accounts}.

Mapforce unfortunately des not allow "-" in the url and proposes a change to

https://wl-api.mf.gov.pl/api/search/bank-accounts/{bank%2Daccounts}

and also proposes change in the parameters for "bank%2Daccounts" but then you can not use this proposed parameter "bank%2Daccounts".

So as you can see I am stuck at this point.


Again any help will be appreciated.

Pawel
Topic: Mapping json array to text file
Posted: Saturday, November 16, 2019 9:24:36 PM
I have a problem when trying to map array of bank accounts for company/entity from json input file to a text file. During mapping the account numbers from json array (when there is more then one bank account) overwritte so from per example 4 bank accounts I have only one output - last account number form array. What I would like to see in the output text file is for each account number in the array there will be additional line of data created (any other data of an entity but account number will be the same) so if entity has 4 bank account numbers in the json array there will be 4 lines of data.

Any help will be grately appreciated.

Pawel.

I am adding json output example, final txt file example with warnings about overwritten bank account string values, screen shot of the mapping.
Topic: REST APi and JSON as a target - problem
Posted: Friday, November 15, 2019 6:56:49 PM
Hello that,

Thank you, for your answer. It works now thanks to you, I have added missing "type":"null" to the json schema.


Pawel
Topic: REST APi and JSON as a target - problem
Posted: Saturday, November 9, 2019 6:23:28 PM
Hello all,

I would like to get some help on the problem that I am experiencing when trying to get and then map an json output/answer from a web REST API.
The problem is that when I get an answer from API using "decode -mime-entity function" I get a json answer as a correct json answer from service please see below. But when I want to provide a json schema to the response with 200 status I don't get any data (like an empty json file). At this point I don't know what I am missing, is the json structure provided a problem?

The REST API service returns data in JSON format. Plsae see also below a sample correct json answer from the service which I want then map to some xls or text file as a source

I will also include a json schema file that I am using as a structure for rest API answer with 200 status and for structure to the output file.

Any help would be much appreciated.

Use of the Altova User Forum(s) is governed by the Altova Terms of Use.