IMPORTANT:
this is not a Support Forum! Experienced users might answer from time to time questions posted here. If you need a professional and reliable answer, or if you want to report a bug, please contact Altova Support instead.

Output EDI with <CR><LF> as the segment Terminator (Hex 85) Options · View
ellerbe
Posted: Friday, June 6, 2008 4:28:48 PM
Rank: Advanced Member

Joined: 10/17/2007
Posts: 56
Location: Seattle
So I have the annoyance of having to use a <CR><LF> as my segment Terminator. The problem is that I can't type in <CR><LF> into the segment terminator. What I can do is type in <LF> and uncheck the check box to begin new line after each segment. When I go to the Output tab this will generate a <CR><LF> segmented EDI file that if I save the output, it imports correctly into my EDI app. Of course the generated code does not match what happens on the Output screen though.

In the EDI prog it is asking for a hex value of 85 which I think is equivalent to the <CR><LF>

If in Mapforce I type in x85 I get a strange … char output (three tiny dots)
I looked up the Ascii chart and it looks like this for 85
Dec Hex Char
133 85 à

But if I put in à for the segment it doesn't work as well.

Unfortunately Ascii code 85 appears to be some sort of standard for EDI so not being able to get it to work with mapforce is disappointing.

At this point I'm not opposed to editing the generated source code but I can't find where it specifies the segment character. Anyone else run into this or find a solution?
that
Posted: Monday, June 9, 2008 9:08:00 AM
Rank: Advanced Member

Joined: 6/16/2006
Posts: 401
Location: AT
CR is x0d
LF is x0a
NEL (next line) is x85
à is xe0 (in ISO-8859-1 or Windows-1252).

In the Windows character set (Windows-1252), x85 is displayed as ellipsis (…) - did you try whether this works in your app?

In any case, the separators are generated from spl/cs/LibraryText/LibraryTextEDI.spl (if you are using C# - for other languages the file name should be similar) into the generated library for the EDI component - near the bottom of the file. If you type x85 into the separator field in MapForce, you should get something like '\u0085' in the generated code.
ellerbe
Posted: Monday, June 9, 2008 5:59:05 PM
Rank: Advanced Member

Joined: 10/17/2007
Posts: 56
Location: Seattle
gah, I was blindsided by thinking it was a segment error. (I did figure out how to get it to output a <CR><LF> by editing the code and setting the segment = '\0' (null)) but anyways thanks for all the help. It turned out to be that when I was connecting a now() to the time F337 that inside of mapforce it would truncate it to 6 characters but the generated code was putting out 12 characters which was blowing up the import into trustedLink(edi software) (of course with out any error message). Well, at least its working now. In order to fix this I connect a time-from-datetime inbetween the now and the F337. It seems I have ran into similar problems before with the output tab not exactly matching the generated code. Of course win-merge is very useful for comparing files and looking for issues like this :)
Users browsing this topic
guest

Forum Jump
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Use of the Altova User Forum(s) is governed by the Altova Terms of Use.