this is not a Support Forum! Experienced users might answer from time to time questions posted here. If you need a professional and reliable answer, or if you want to report a bug, please contact Altova Support instead.

MapForce 2020 Substring Function Issue Options · View
Posted: Wednesday, August 26, 2020 8:54:58 PM
Rank: Newbie

Joined: 8/26/2020
Posts: 1
Location: Virginia
I recently worked with your support team on a license issue. However, now I have an issue that I cannot seen to solve in MapForce 2020.

I am trying to parse a string by using the substring function. Below is an example of what I am trying to accomplish.

Example: "071317"

substring('071317',1,2) -(This is a MapForce substring function)

return value: "7"

- The leading zero gets stripped off. I cannot seem to preserve the leading zero. I have tried several things but was not successful.
Posted: Thursday, August 27, 2020 11:17:31 AM
Rank: Advanced Member

Joined: 9/9/2005
Posts: 483
Location: AT

Is the target node that you are mapping this value to a 'string' data type? If not then try changing it to be one...
Users browsing this topic

Forum Jump
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Use of the Altova User Forum(s) is governed by the Altova Terms of Use.