Habilite JavaScript para visualizar esta página.

Altova UModel 2020

El comando Herramientas | Opciones abre el cuadro de diálogo "Opciones locales".

 

En la pestaña Vista puede definir:

donde debe aparecer el logotipo del programa.

el contenido de la barra de título de la aplicación.

el tipo de elementos que deben aparecer en la lista generada por el comando Mostrar elementos no utilizados en ningún diagrama del menú contextual de los paneles Estructura del modelo y Favoritos. También tiene la opción de omitir los elementos de los archivos incluidos.

si un elemento seleccionado de un diagrama se selecciona/sincroniza automáticamente o no en la Estructura del modelo.

la profundidad predeterminada de la vista jerárquica generada por el comando Mostrar en forma de diagrama en la ventana Jerarquía.

la profundidad de los niveles de la ventana Jerarquía (con las opciones del grupo Autodiseño de la jerarquía).

que se expanda solo uno de los clasificadores del mismo tipo de la misma imagen / del mismo diagrama ( con la opción Expandir cada elemento solo una vez).

si se habilitan las líneas de ajuste para ayudarle durante la alineación de elementos en el diagrama.

 

um_dlg_options_view

En la pestaña Edición puede definir:

que cuando se cree un diagrama nuevo en la Estructura del modelo, el diagrama se abra automáticamente en el área de trabajo.

el nivel de acceso predeterminado de los elementos nuevos (propiedades y operaciones).

el lenguaje de código predeterminado para los componentes nuevos.

si las restricciones también deben restringir automáticamente su propietario.

si debe aparecer un aviso cuando se eliminen elementos del proyecto, de la ventana Favoritos o de un diagrama. Este aviso se puede desactivar cuando se eliminen elementos.

cuánto tardan en cerrarse los mensajes emergentes de error de sintaxis.

um_dlg_options_editing

 

En la pestaña Edición de diagramas puede definir:

cuántos elementos se pueden añadir automáticamente a un diagrama sin que aparezca un aviso.

la presentación de los estilos cuando se añaden automáticamente a un diagrama.

si se debe crear automáticamente asociaciones entre los elementos de modelado cuando se añaden elementos a un diagrama.

si se deben resolver las asociaciones a colecciones.

si las plantillas de elementos externos desconocidos se deben resolver como plantillas no completas.

o si se deben usar plantillas de colecciones ya disponibles o definir plantillas nuevas.

Debe definir las plantillas de colecciones como plantillas completas (es decir, a.b.c.Lista). Si la plantilla tiene este espacio de nombres, UModel crea una asociación de colecciones automáticamente. Excepción: si la plantilla pertenece al paquete Elementos externos desconocidos y está habilitada la opción Externos desconocidos: resolver nombre incompleto, entonces se tiene en cuenta el nombre de la plantilla solamente (es decir, Lista en lugar de a.b.c.Lista).

si la ventana de finalización automática está disponible mientras se editan atributos u operaciones en los diagramas de clases.

 

 um_dlg_options_diagram

 

En la pestaña Archivo puede definir:

qué ocurre cuando los archivos cambian.

si el contenido de la ventana Favoritos y los diagramas abiertos deben cargarse y guardarse con el proyecto actual.

si el último proyecto que se abrió se debe abrir automáticamente cuando se inicia la aplicación.

si se añaden retornos de carro/saltos de línea y tabulaciones al archivo de proyecto para darle formato pretty-print.

 

um_dlg_options_file

En la pestaña Ingeniería de código puede definir:

en qué circunstancias se abre la ventana Mensajes.

si se revisan todos los elementos de código (es decir, los que están en una raíz de espacio de nombres Java / C# / VB y los que están asignados a un componente Java / C#  / VB) o solo los elementos utilizados para ingeniería de código (es decir, los que tienen activa la casilla Usar para ingeniería de código).

si durante la actualización del código de programa:

ose revisa la sintaxis o no.

ose generan automáticamente las RealizacionesDeComponente que faltan o no.

ose generan los nombres de archivo de código que faltan en el código combinado o no.

ose utilizan espacios de nombres en la ruta de acceso del archivo de código o no.

el tipo de sangría que se aplica al código (es decir, tabulaciones o espacios).

qué directorios se omiten cuando se actualice un proyecto de UModel con código. Separe los directorios con un punto y coma. Los directorios secundarios que se llamen igual también se pasarán por alto.

la ubicación del archivo de catálogo de XMLSpy RootCatalog.xml, que permite a UModel y a XMLSpy recuperar esquemas, hojas de estilos y otros archivos utilizados con frecuencia desde carpetas de usuario locales. Esto aumenta la velocidad de procesamiento y permite al usuario trabajar sin conexión.

um_dlg_options_code

En la pestaña Control de código fuente puede definir:

el complemento de control de código fuente actual. Con el botón Opciones avanzadas puede configurar algunas opciones avanzadas del sistema de control de código seleccionado. Estas opciones avanzadas dependen del control de código fuente elegido.

el id. de inicio de sesión para el proveedor de control de código fuente.

otras opciones relacionadas con la protección y desprotección de archivos.

el botón Restaurar se habilita si el usuario marca la casilla No volver a mostrar en un cuadro de diálogo. Con el botón Restaurar puede volver a habilitar los avisos.

um_dlg_options_source

© 2019 Altova GmbH