Herstellen einer Verbindung zu einem Webservice und Öffnen von Dateien

www.altova.com Dieses Kapitel drucken Vorherige Seite Eine Ebene nach oben Nächste Seite

Startseite >  Benutzerhandbuch und Referenz > WSDL und SOAP > WSDL Tutorial >

Herstellen einer Verbindung zu einem Webservice und Öffnen von Dateien

In diesem Abschnitt wird Folgendes beschrieben:

 

Zugriff auf einen Webservice mittels XMLSpy
Öffnen einer WSDL-Datei im Web in XMLSpy
Öffnen eines mit dem WSDL-Dokument verknüpften XML-Schemas in XMLSpy

 

Zugriff auf einen Webservice

Ein Webservice wird normalerweise über eine HTML-Seite wie z.B. DebuggerClient.htm aufgerufen. Im Projekt Examples/SoapDebugger finden Sie einen Link dazu. Um den auf dieser Seiten angezeigten Webservice aufzurufen, gehen Sie folgendermaßen vor:

 

1.Aktivieren Sie das Projektfenster, falls es nicht zu sehen ist (über die Menüoption Fenster | Projekt-Fenster).
2.Klicken Sie auf das Erweiterungssymbol neben dem Ordner "SOAP Debugger" und doppelklicken Sie auf die Datei DebuggerClient.htm. Daraufhin wird im Hauptfenster der SOAP Debugger Beispiel Client geöffnet.

wsdl-tut-tserv2

 

Öffnen einer WSDL-Datei in XMLSpy

Um eine webbasierte WSDL-Datei in XMLSpy zu öffnen, gehen Sie folgendermaßen vor:

 

1.Wählen Sie die Menüoption Datei | Öffnen und klicken Sie in im Dialogfeld "Öffnen" auf die Schaltfläche Zu URL wechseln. Geben Sie dann die Adresse http://www.nanonull.com/TimeService/TimeService.asmx?WSDL in das Feld "Datei-URL" ein oder kopieren Sie sie hinein.

wsdl-tut-tserv3

2.Klicken Sie auf OK, um die WSDL-Datei zu laden. Die WSDL-Datei wird in der Text-Ansicht angezeigt.

 

3.Wählen Sie die Menüoption Datei | Speichern unter und speichern Sie die Datei lokal z.B. unter dem Namen timeservice.wsdl.
4.Klicken Sie auf das WSDL-Ansichtsregister, um die Datei im grafischen WSDL-Editor anzuzeigen.

 

Anzeigen der mit der aktiven WSDL-Datei verknüpften Schema-Datei

Während im Hauptfenster die Datei timeservice.wsdl das aktive Dokument ist, wählen Sie die Menüoption WSDL | Types | Schema(s) in Schema-Ansicht bearbeiten. Daraufhin wird die Schema-Datei geöffnet, in der alle in der Datei timeservice.wsdl verwendeten Datentypen definiert sind. Sie können das Schema ändern und die Änderungen speichern. Diese Änderungen werden erst dann in der WSDL-Datei übernommen, sobald die Datei erneut geparst wird.

 


© 2019 Altova GmbH