Altova DiffDog 2022 Enterprise Edition

Toolbar Icons

Home Prev Top Next

Icons in the toolbar are shortcuts for various commands, most of which are also available as menu commands. You can make any toolbars visible/invisible using the Toolbars tab of the Customize dialog (Tools | Customize). To move a toolbar, drag its handle to the desired location. The available toolbars are described below.

 

Standard toolbar

The Standard toolbar (see screenshot below) contains file and general editing commands, which can also be accessed in the File, Edit, and XML menus.

__tb_standard-ent

 

Comparison toolbars

The Comparison Mode toolbar (see screenshot below) enables you to select a comparison mode for files and directories. This group of commands is available in the Diff and Merge menu.

tb_comparison-mode

The Diff and Merge toolbar (see screenshot below) enables you to start comparisons, navigate through differences between files, merge differences, and set application and comparison options. All these commands are available in the Diff and Merge menu and in the Tools menu.

tb_diff-and-merge

The Directory Content toolbar (see screenshot below) enables you to configure the display of Directory Comparison windows. Note that—except for the directory synchronization commands, which are included in the Diff and Merge menu—these commands are available only as toolbar buttons. To find out more about commands in the Directory Content toolbar, see Configuring the View and Running a Directory Comparison.

tb_directory-content

The Word Comparison toolbar enables you to configure the display of Word Comparison windows. Note that these commands are available only as toolbar buttons. For more information about commands in the Word Comparison toolbar, see Configuring the Word Comparison Window.

tb_word

The Database Data Comparison Mode toolbar (see screenshot below) enables you to select a comparison mode for database data. These commands are also available in the Diff and Merge menu.

tb_db-data-comp-mode

The Database Data Comparison Result toolbar (see screenshot below) enables you to configure the display of Database Data Comparison Result windows. For more information about commands in the Database Data Comparison Result toolbar, see Viewing Differences Between Tables.

tb_db-data-comp-result

The 3-way Comparison toolbar (see screenshot below) enables you to navigate and merge differences in three-way comparisons.

dd_3way_toolbar

 

Text/grid view

The Grid toolbar (see screenshot below) is enabled in Grid View in File Comparison windows. With the Grid commands, you can make structural editing changes and modify the Grid View of your XML document. Only well-formed XML documents can be seen in Grid View mode.

tb_grid

The commands below, which are available only as toolbar buttons, enable you to take the following actions in Grid View mode:

 

ic_expand-all-selected (Expand all selected): Expands one or more selected nodes in Grid View.

ic_collapse-all-selected (Collapse all selected): Collapses the selected nodes.

ic_fully-expand-all-selected (Fully expand all selected): Expands all selected nodes and their descendant nodes.

ic_collapse-unselected (Collapse unselected): Collapses all selected nodes and their descendant nodes.

ic_optimal-widths (Optimal widths): Sets columns to optimal widths.

 

The Text toolbar (see screenshot below) enables you to configure the display and navigation features of Text View. All these commands are available as Text View menu commands.

tb_text-view

Icons in the Grid Edit toolbar (see screenshot below) are used for editing in Grid View. For information about these commands, see Grid View Menu. This toolbar is deactivated by default. If you want to make the toolbar visible in the interface, select the menu command Tools | Customize and check the box Grid Edit in the Toolbars tab.

tb_grid-edit

 

© 2016-2022 Altova GmbH