Aktivieren Sie bitte JavaScript, um diese Seite anzeigen zu können.

Altova Authentic 2020 Desktop

Das Authentic Desktop-Installationspaket enthält ein Java-Beispielprojekt, das Sie Ordner "ActiveX Examples" des Applikationsordners <ApplicationFolder>\Examples\ActiveX\Java\ finden.

 

Im Java-Beispiel wird gezeigt, wie Sie das AuthenticDesktopControl in eine mit Java erstellte Desktop Applikation integrieren können. Sie können das Beispielprojekt mit Hilfe der Batch-Datei BuildAndRun.bat, direkt über die Befehlszeile testen oder Sie können es in Eclipse kompilieren und ausführen. Anleitungen dafür finden Sie weiter unten.

 

Dateiliste

Der Ordner für die Java-Beispiele enthält alle zum Ausführen des Beispielprojekts erforderlichen Dateien. Diese Dateien sind unten aufgelistet:

 

 

.classpath

Hilfedatei Eclipse-Projekt

.project

Eclipse-Projektdatei

AltovaAutomation.dll

Java-COM Bridge: DLL-Teil (für die 32-Bit-Installation)

AltovaAutomation_x64.dll

Java-COM Bridge: DLL-Teil (für die 64-Bit-Installation)

AltovaAutomation.jar

Java-COM Bridge: Java-Bibliotheksteil

AuthenticActiveX.jar

Java-Klassen des Authentic Desktop ActiveX Control

AuthenticActiveX_JavaDoc.zip

Javadoc Datei, die die Hilfedokumentation für die Java API enthält

AuthenticDesktopContainer.java

Java-Beispielquellcode

AuthenticDesktopContainerEventHandler.java

Java-Beispielquellcode

BuildAndRun.bat

Batch-Datei zum Kompilieren und Ausführen des Beispielcodes über die Befehlszeile. Es wird ein Ordner benötigt, in dem sich die Java Virtual Machine als Parameter befindet.

XMLTreeDialog.java

Java-Beispielquellcode

 

 

Funktionen in diesem Beispiel

Im Beispiel werden ein AuthenticDesktop Dokument-Editor-Fenster, das Projektfenster, das Info-Fenster und eine Authentic-Eingabehilfe in ein AWT-Rahmenfenster platziert. Das für Authentic definierte Menü "Datei" wird ausgelesen und ein AWT-Menü mit derselben Struktur wird erstellt. Über dieses Menü oder über das Projektfenster können Sie Dateien im Dokument-Editor öffnen und damit arbeiten.

 

 

Sie können das Beispiel nach Ihren Wünschen modifizieren.

 

In den Codefragmenten werden die folgenden spezifischen Schritte beschrieben:

 

Erstellen der ActiveX Controls: Startet Authentic Desktop, das als Automation Server registriert ist, bzw. aktiviert das Programm, wenn Authentic Desktop bereits ausgeführt wird.

Laden der Daten in die Controls: Navigiert zu einem der mit Authentic Desktop installierten Beispieldokumente und öffnet es.

Grundlegendes zur Event-Behandlung: Wechselt von der Ansicht aller offenen Dokumente in die Textansicht. Im Code wird auch gezeigt, wie man durch offene Dokumente iteriert.

Menüs: Validiert das aktive Dokument und zeigt das Ergebnis in einem Meldungsfeld an. Im Code wird gezeigt, wie Ausgabeparameter verwendet werden.

Behandlung von UI Update Events: Zeigt, wie Authentic Desktop Events behandelt werden.

Erstellen einer XML-Baumstruktur: Zeigt wie, Sie eine XML-Baumstruktur erstellen und sie für die modale Aktivierung vorbereiten.

 

Aktualisieren des Pfads zum Ordner "Examples"

Bevor Sie das zur Verfügung gestellte Beispiel ausführen, müssen Sie die AuthenticDesktopContainer.java-Datei möglicherweise bearbeiten und überprüfen, ob der folgende Pfad auf den tatsächlichen Ordner verweist, in dem die Authentic Desktop Beispieldateien auf Ihrem Betriebssystem gespeichert sind.

 

// Locate samples installed with the product.
final String strExamplesFolder = System.getenv( "USERPROFILE" ) + "\\Documents\\Altova\\Authentic2020\\AuthenticExamples\\";

 

Ausführen des Beispiels über die Befehlszeile

So führen Sie das Beispiel über die Befehlszeile aus:

 

1.Überprüfen Sie, ob alle Voraussetzungen erfüllt werden (siehe Voraussetzungen).

2.Öffnen Sie ein Eingabeaufforderungsfester, wechseln Sie in den Java-Beispielprojektordner und geben Sie folgende Zeile ein:

buildAndRun.bat "<Pfad-zum-Java-bin-Ordner>"

1.Drücken Sie die Eingabetaste.

 

 

Der Java-Quellcode in AuthenticDesktopContainer.java wird kompiliert und anschließend ausgeführt.

 

Kompilieren und Ausführen des Beispiels in Eclipse

So importieren Sie das Java-Beispielprojekt in Eclipse:

 

3.Überprüfen Sie, ob alle Voraussetzungen erfüllt werden (siehe Voraussetzungen).

1.Klicken Sie im Menü File auf Import.

2.Wählen Sie Existing Projects into Workspace und navigieren Sie zur Eclipse-Projektdatei unter <ApplicationFolder>\Examples\ActiveX\Java\. Da Sie möglicherweise keinen Schreibzugriff auf diesen Ordner haben, wird empfohlen, im Importdialogfeld das Kontrollkästchen Copy projects into workspace zu aktivieren.

 

Um die Beispielapplikation zu starten, klicken Sie mit der rechten Maustaste im Package Explorer auf das Paket und wählen Sie den Befehl Run as | Java Application.

 

Hilfe zu Java API-Klassen steht in Form von Kommentaren im Code sowie als Javadoc-Ansicht von Eclipse zur Verfügung. Um die Javadoc-Ansicht in Eclipse zu aktivieren, wählen Sie den Menübefehl Window | Show View | JavaDoc.

© 2019 Altova GmbH