Altova Authentic 2023 Desktop

Browser View

Home Prev Top Next

Browser View is typically used to view:

 

XML files that have an associated XSLT file. When you switch to Browser View, the XML file is transformed on the fly using the associated XSLT stylesheet and the result is displayed directly in Browser View.

HTML files which are either created directly as HTML or created via an XSLT transformation of an XML file.

 

To view XML and HTML files in Browser View, click the Browser tab.

 

Browser engines in Browser View

By default, Browser View currently uses Microsoft's Internet Explorer as its browser engine. If you wish to use Microsoft's newer Edge WebView2 browser engine for Browser View, you can select this option in the View section of the Options dialog.

 

Note:Since Microsoft Edge WebView2 uses the Chromium software project, on which Google's Chrome browser is based, using WebView2 for Browser View also provides a good preview of the Chrome display of a web page.

 

Notes about Microsoft Internet Explorer

Browser View requires Microsoft's Internet Explorer 5.0 or later, or Microsoft Edge WebView2 (see above).

 

Note the following points about Internet Explorer in Browser View:

 

If you wish to use Browser View for viewing XML files transformed by an XSLT stylesheet, we strongly recommend Internet Explorer 6.0 or later, which uses MSXML 3.0, an XML parser that fully supports the XSLT 1.0 standard. You might also wish to install MSXML 4.0.

Support for XSLT in IE 5 is not 100% compatible with the official XSLT Recommendation. So if you encounter problems in Browser View with IE 5, you should upgrade to IE 6 or later.

In general, you should check the support for XSLT of your version of Internet Explorer.

If you encounter problems with the correct display of HTML in Internet Explorer, include the following meta tag in the head element of your HTML document:

<head>

... <meta http-equiv="X-UA-Compatible" content="ie=edge">...

</head>

 

Developer tools in Browser View

You can use the Developer Tools of the Edge browser to inspect, debug, and test your HTML code. To open the tools, right-click in the Browser View pane and select Open Developer Tools.

 

Browser View features

The following features are available in Browser View. They can be accessed via the Browser menu, File menu, and Edit menu.

 

Open in separate window: When Browser View is a separate window, it can be positioned side-by-side with an editing view of the same document. To do this, click the menu command Browser | Separate Window. This is a toggle command that switches Browser View between two windows: (i) a separate window, and (ii) a tabbed view in the Main Window. These commands are also available in the dropdown menu of the Browser View button (at the bottom of the Main Window).

Forward and Back: The common browser commands to navigate through pages that were loaded in Browser View. These commands are in the Browser menu.

Font size: Can be adjusted via the Browser menu.

Stop, Refresh, Print: More standard browser commands, these can be found in the Browser and File menus.

Find: Enables searches for text strings. This command is in the Edit menu.

Info Window: There are options here to view the active HTML page with any of the web browsers installed on the machine and to open or remove the installed browsers.

 

 

© 2016-2022 Altova GmbH