Internet Explorer

www.altova.com Dieses Kapitel drucken Vorherige Seite Eine Ebene nach oben Nächste Seite

Startseite >  Einrichten des Servers > HTML-Seite für das Authentic Plug-in >

Internet Explorer

Wenn die HTML-Seite für das Authentic Plug-in in Internet Explorer (32-Bit oder 64-Bit) geöffnet werden soll, muss sie die folgenden Elemente enthalten:

 

ein HTML OBJECT-Element, das (i) die richtige DLL für das Authentic Plug-In (32-Bit oder 64-Bit) vom Server auf den Client lädt und (ii) die Größe des Authentic-Fensters im Browser des Client definiert. Das OBJECT-Element enthält den Pfad zum Authentic Browser Plug-in. Beachten Sie, dass das Authentic Plug-in in einer Version für die 32-Bit- und in einer Version für die 64-Bit-Version von Internet Explorer zur Verfügung steht (außer für die 64-Bit-Version von IE 10 und 11), daher muss die richtige Authentic Browser Plug-in-Version (.cab Datei) auf den Client heruntergeladen werden. Beispielcode, der die X-Bit Verson von Internet Explorer automatisch überprüft und das richtige Authentic Plug-in herunterlädt, finden Sie im Abschnitt Browser-unabhängiges Beispiel.
eines oder mehrere HTML SCRIPT-Elemente. Ein SCRIPT-Element definiert die verschiedenen Subroutinen, die in der HTML-Seite und bei der Ereignisverarbeitung verwendet werden. Mit Hilfe eines SCRIPT-Elements können Sie definieren, welches XML-Dokument bearbeitet werden soll und welches XML-Schema und welche SPS-Datei dem XML-Dokument zugrunde gelegt werden soll.

 

Dieser Abschnitt

Dieser Abschnitt ist in die folgenden Unterabschnitte gegliedert:

Das OBJECT-Element: Hier wird beschrieben, wie das HTML OBJECT Element in einer HTML-Seite für das Authentic Plug-in verwendet wird.
Das SCRIPT-Element: Hier wird beschrieben, wie HTML SCRIPT Elemente in einer HTML-Seite für das Authentic Plug-in verwendet werden.
Beispiele für komplette HTML-Seiten: IE Beispiel 1, einfach und IE Beispiel 2: Tabelle sortieren.

 

Informationen zu einzelnen Objekten finden Sie im Abschnitt "Benutzerreferenz" unter der entsprechenden Object-Beschreibung.

 

 

Hinweis:Das Authentic Browser Plug-in wird für Internet Explorer 5.5 oder höher unterstützt, allerdings wird die 64-Bit-Version von Internet Explorer 10 und 11 nicht unterstützt.

 


© 2019 Altova GmbH