Importieren von Daten aus XML-Dateien

www.altova.com Dieses Kapitel drucken Vorherige Seite Eine Ebene nach oben Nächste Seite

Startseite >  Tutorials > Datenbank "ZooDB" > Einfügen von Daten in die Datenbank >

Importieren von Daten aus XML-Dateien

In der vorhergehenden Lektion haben Sie gelernt, wie man Daten mit Hilfe von Textdateien in eine Datenbank einfügt. In DatabaseSpy können Sie auch XML-Dateien verwenden, um Daten in aus einer Datenbank zu exportieren oder in eine Datenbank zu importieren. Im Tutorial-Ordner Ihrer DatabaseSpy-Installation befinden sich zu diesem Zweck auch Beispiel-XML-Dateien.

 

In diesem Schritt werden Sie Daten aus dbo.tblFeedSuppliers.xml in die Datenbanktabelle tblFeedSupplier importieren. Wir gehen davon aus, dass Sie diese Tabelle noch nicht auf eine andere Art (z.B. durch Import der Daten aus tblFeedSuppliers.txt in die Tabelle, siehe Importieren von Daten aus TXT-Dateien) mit Daten befüllt haben.

 

So importieren Sie Daten aus einer XML-Datei in die Datenbank:

1.Klicken Sie in der Extras-Symbolleiste auf die Schaltfläche Importieren ic_import oder wählen Sie die Menüoption Extras | Daten in Datenbank importieren... oder drücken Sie Strg+I. Daraufhin wird das Dialogfeld Daten in die Datenbank importieren geöffnet.
2.Klicken Sie auf der linken Seite des Dialogfelds auf das Symbol XML.
3.Klicken Sie auf dem Register "Auswahl" auf die Schaltfläche ic_browse neben dem Feld Pfad. Wählen Sie im Unterverzeichnis \Altova\DatabaseSpy2019\DatabaseSpyExamples\Tutorial des Ordners Dokumente die Datei dbo.tblFeedSuppliers.xml aus.
4.Aktivieren Sie unter Datenbankgenerierungs-Optionen die Option Vorhandene Tabellen aktualisieren.
5.Wählen Sie unter Importmodus den Modus SQL in SQL Editor generieren.
6.Klicken Sie auf das Register Optionen.
7.Wählen Sie unter Import beginnt in der Liste Beginn bei den Eintrag "Row" aus. (Damit definieren Sie den Namen des XML-Elements, aus dem Daten importiert werden sollen).
8.Deaktivieren Sie unter Generiere automatische Felder das Kontrollkästchen Primär-/Sekundärschlüssel.
9.Wählen Sie unter Weitere Optionen die Option Namespace-Namen ausnehmen.
10.Klicken Sie unter Vorschau auf die Schaltfläche Optionen anwenden. Daraufhin werden die Tabellendaten im Vorschaufenster angezeigt. Beachten Sie, dass das Importelement nun nicht mehr zur Auswahl steht. Um die Tabellendefinition anzuzeigen, aktivieren Sie das Optionsfeld Definition anzeigen.
11.Klicken Sie in die Spalte Zieltabellenname und wählen Sie dbo.tblFeedSuppliers.xml aus Dropdown-Liste aus.
12.Klicken Sie auf das Tabellensymbol ic_include-col von "TreatmentID" bis stattdessen das Symbol für nicht zu importierende Spalten ic_exclude-col angezeigt wird. Über die Spaltenüberschrift können Sie festlegen, ob er beim Import inkludiert werden soll. Die Spalte "TreatmentID" wird von uns nicht importiert, da es sich hierbei um eine ID-Spalte handelt und der Primärschlüssel beim Import automatisch generiert wird.

 

Wenn Sie die Anweisung bis jetzt befolgt haben, sehen Sie die in der Abbildung unten gezeigten Importoptionen (die beiden Abbildungen unten zeigen das Register Auswahl und das Register Optionen).

dbs_import_xml_selection_tab

XML-Importoptionen auf dem Register "Auswahl"

 

 

dbs_import_xml_options_tab

XML-Importoptionen auf dem Register "Optionen"

 

13.Klicken Sie auf die Schaltfläche SQL generieren. Daraufhin wird ein SQL Script generiert, welches ausgeführt werden kann, um den Import fertig zu stellen. Klicken Sie im Meldungsfeld auf OK, um das Script im SQL Editor anzuzeigen.
14.Klicken Sie auf die Schaltfläche Ausführen ic_execute-sql oder drücken Sie F5.
15.Klicken Sie im Online Browser mit der rechten Maustaste auf die Datenbank ZooDB und wählen Sie im Kontextmenü den Befehl Aktualisieren.
16.Klicken Sie mit der rechten Maustaste auf die Tabelle tblMedicalTreatments und wählen Sie im Kontextmenü den Befehl Daten abrufen | Alle Zeilen oder drücken Sie Strg+Alt+R.

 

sql_retrieve-medical-treatments


© 2019 Altova GmbH