XMLSpy スタンドアロンとの違い

www.altova.com このトピックを印刷 前のページ 1つ上のレベル 次のページ

ホーム >  ユーザーマニュアル > Visual Studio 内の XMLSpy >

XMLSpy スタンドアロンとの違い

このセクションでは Visual Studio バージョンとスタンドアロンバージョンの XMLSpy の違いについて説明します。まずは Visual Studio バージョンでサポートされていない機能について、そしてスタンドアロンバージョンの Visual Studio 間で動作が異なる点について説明します。

 

Visual Studio ではサポートされない機能
Visual Studio で追加された XMLSpy メニュー
入力ヘルパー (Visual Studio のツールウィンドウ )
異なるコマンドによる同等の機能
Visual Studio コマンドとして使える XMLSpy  コマンド

 

Visual Studio ではサポートされない機能

Visual Studio では以下の XMLSpy の機能がご利用になれません:

 

スクリプティング環境(「ツール | XMLSpy オプション」 メニューオプションの 「スクリプト」 タブ)は現在サポートされていません。
メニューオプションの 「ツール | ツール」 「ビュー」 タブにある、ブラウザービューを別のウィンドウに表示するオプションがサポートされていません。つまりテキストビューとテキストビューは常に同じウィンドウで表示されます。
Authentic View の状態アイコンがサポートされていません。
全てのソース管理機能がサポートされていません。
(スタンドアロンバージョンでは 「ツール」 メニューオプションから利用できる)全ての比較機能がサポートされていません。

 

Visual Studio で追加された XMLSpy メニュー

以下のコマンドは Visual Studio バージョンの XMLSpy だけでご利用になれます:

 

表示 | XMLSpy ツールウィンドウ
表示 | XMLSpy 表示
XMLSpy (グローバルリソースメニューアイテムが含まれます)
ツール | XMLSPY オプション

 

入力ヘルパー (Visual Studio のツールウィンドウ )

XMLSpy の入力ヘルパーは Visual Studio のツールウィンドウとして使用することができます。入力ヘルパーに関して、以下の点に注意してください。入力ヘルパーと XMLSpy の GUI に関しては、イントロダクションを参照ください。

 

入力ヘルパーウィンドウは開発環境内のどのような場所にでもドラッグすることができます。
入力ヘルパータブを右クリックすることで、インターフェースを更にカスタマイズすることができます。入力ヘルパーのオプションは:フローティング、ドッキング可能、タブ付きドキュメント、自動的に隠す、です。

 

異なるコマンドによる同等の機能

以下の表に示されるように、XMLSpy の機能によっては、Visual Studio にて異なるコマンド名で表示されます。

 

XMLSpy

Visual Studio

機能

ファイル | 開く | URL にスイッチ

ファイル | 開く | Web サイト

URL からファイルを開く

ファイル | 名前を付けて保存 | URL にスイッチ

ファイル | XMLSpy ファイルを URL に保存

ファイルを URL に保存

 

Visual Studio コマンドとして使える XMLSpy コマンド

いくつかの XMLSpy コマンドは Visual Studio コマンドとして Visual Studio GUI に表示されます:

 

元に戻す、やり直し :これらの Visual Studio コマンドは、Visual Studio 開発環境全てに対して適用されます。
プロジェクト: XMLSpy プロジェクトは Visual Studio プロジェクトとして扱われます。
ツールバーのカスタマイズ、コマンドのカスタマイズ :(以下のスクリーンショットにある)ユーザー設定ダイアログ(「ツール | ユーザー設定」)内のツールバーならびにコマンドタブには Visual Studio と XMLSpy のコマンドが含まれます。

net-cust-keyb

表示 表示メニュー以下の XMLSpy ツールウィンドウXMLSpy ビューの2つのコマンドには、入力ヘルパーや他のサイドバー、編集ビュー間の切り替え、そして特定の入力ガイドの有効/無効を切り替えるオプションが含まれています。
XMLSpy ヘルプ: この XMLSpy メニューは Visual Studio 「ヘルプ」 メニューのサブメニューに表示されます。

 


(C) 2018 Altova GmbH