メニューとツールバー

www.altova.com このトピックを印刷 前のページ 1つ上のレベル 次のページ

ホーム >  XMLSpy チュートリアル > XMLSpy インターフェイス >

メニューとツールバー

チュートリアルのこのセクションでは、 XMLSpy のメニューとツールバーの機能を学習します。

 

メニュー

2 つのメニューバーがあります: (i) ドキュメントが開かれていない時に表示されるデフォルトメニュー、および (ii)ドキュメントが開かれると表示される XMLSpy アプリケーションメニュー全体。以下を行ってください:

 

1.メニューコマンド 「ファイル | 閉じる」 を使用してすべての開かれているドキュメントを閉じます。 デフォルトのメニューが表示されます。
2.AddressFirst.xsd ファイルを 「ファイル」 メニューの下にある最近開かれたファイルのリストからクリックして開きます。ファイルがスキーマビューで開かれている場合、メニューは XMLSpy アプリケーションメニューに変更されます。

 

 

メニューは主に機能により整理されており、メニュー内のコマンドは、カーソルポイントまたはアクティブドキュメントの現在のビューの選択の場合のみ実行することができます。 メニューコマンドが有効化または無効化されているかを決定する要素を理解するためには以下を行います :

 

1.「スキーマデザイン」 メニューをクリックします。 「図の保存」「表示設定」、および 「ズーム」 コマンドが無効化されていることに注意してください (下のスクリーンショット)。

TutMenu01

2.メニューの外側の空白をクリックして、メニューを消します。 要素コンポーネントの左横にある 図の表示 アイコン ic_component をクリックします。これによりスキーマビューのコンポーネントモデルビューに移動します (スキーマビューの 2 番目のビュー; 1 番目のビューはスキーマ概要です)。スキーマデザインメニューを確認すると、 「図の保存」「表示設定」、および 「ズーム」 コマンドが有効化されていることが確認できます。これらのコマンドはスキーマビューのコンテンツモデルビュー内のみで有効化されますが、スキーマビューのスキーマ概要またはその他のビューでは有効化されません。  XML スキーマファイルはスキマービューのみで開かれることに注意してください。
3.XML スキーマファイルもまた XMLファイルですから、このファイルもまたテキストビューおよびグリッドビューで XML ファイルとして表示されます。 XML ファイルに対して適用することのできるメニューコマンドすべてはこれらのビューで有効化されます。スキーマビューとテキストビュー内の 「編集」 メニューのコマンドを (有効化または無効化されているかを)比較してください。
4.次に、テキストビューとグリッドビューの 「XML | 挿入」 メニュー内のコマンドを(有効化または無効化されているかを)比較してください。このメニュー内のコマンドはグリッドビューのみで有効化されています。

 

全てのメニューコマンドの詳細に関しては、ユーザーマニュアルの「ユーザーレファレンス」 のセクションを参照してください。

 

ツールバー

ツールバーの表示は現在のビューにより異なります。アプリケーションのデフォルトの設定は各ビューの正しいツールバーを表示します、ツールバーは各ビューによって異なります。 ですが、カスタマイズダイアログ内のツールバー(「ツール | カスタマイズ | ツールバー」、 下のスクリーンショット)によりカスタム化することができます。

new_mnu_customize_toolb

ツールバーを GUI の周辺で移動させる練習をしてください。ツールバーのハンドルをクリックして、 GUI 内の希望する場所にドラッグします。 (ツールバーハンドルは各ツールバーの左横にある垂直の点線で表示されています。 下のスクリーンショット参照)。

TutToolbar01

以下の場所にツールバーをドラッグします: (i) ツールバーエリア内の他のライン、(ii) 他のツールバーの左側または右側l、 (iii) メインウィンドウの中央、 (iv) アプリケーションウィンドウの左側または右側 (この操作には、グラッブするハンドルがアプリケーションウィンドウの左側または右側の上に置かれる必要があります)。

 

終了すると AddressFirst.xsd ファイルを閉じます。

 


(C) 2019 Altova GmbH