メイン ウィンドウ

www.altova.com このトピックを印刷 前のページ 1つ上のレベル 次のページ

ホーム >  ユーザーマニュアル > インターフェイスと環境 > グラフィカルユーザインターフェース (GUI) >

メイン ウィンドウ

(以下の図に表示される)メインウィンドウではドキュメントの編集を行ないます。

 

mainwindow

 

メインウィンドウのファイル

 

開いたり編集を行うファイルの数に制限はありません。
開かれた各ドキュメントは、各自ウィンドウに表示され、その名前がメインウィンドウの下部にあるタブに表示されます。ドキュメントをアクティブにするには、そのドキュメントのタブをクリックしてください。
複数のファイルが開かれている場合、ドキュメントタブバーに収まりきらず、一部のドキュメントタブが表示されないことがあります。目的のドキュメントタブは、(i) ドキュメントタブバーの右にあるスクロールボタンを使うことで、または (ii) ウィンドウ メニューから目的のドキュメントを選択することでアクティブにすることができます。
アクティブなドキュメントが最大化されると、「最小化」「元に戻す」、「閉じる」ボタンがメニューバーの右側に配置されます。ドキュメントが重ねて表示、または最小化されると、「最大化」、「元に戻す」、「閉じる」ボタンがドキュメントウィンドウのタイトルバーに配置されます。
1つのファイルを最大化すると、開かれている他のファイルも全て最大化されます
ウィンドウ メニューのコマンドを使用することで、開かれているドキュメントを重ねて、または上下(左右)に並べて表示することができます。
開かれているファイルは、 「Ctrl+Tab」 または 「Ctrl+F6」により、開かれた順序でアクティブに切り替えることができます。
ドキュメントタブを右クリックすることで表示されるコンテキストメニューから、「印刷」や「閉じる」といったコマンドを実行することができます。

 

メインウィンドウ内のビュー

アクティブなドキュメントを表示、編集する方法は何通りかあります。使用することのできるビューは、(上の図にあるように)ドキュメントタブ上のバーに表示されており、アクティブなビューがハイライトされます。目的のビューボタンをクリック、または 表示 メニューのコマンドを使用することでビューの切り替えを行うことができます。

 

利用可能なビューは編集またはブラウザビューです:

 

テキストビュー: 構文による色分けなどの機能を備えたソースコードレベルの編集を行うビュー
グリッドビュー: 構造化された編集を行うビュー。グラフィカルな編集を行うことのできる構造化されたグリッドの形式で、ドキュメントは表示されます。このビューには テーブルビュー が内蔵されており、繰り返し出現する要素をテーブル形式で表示することができます。
スキーマビュー: XML スキーマの表示や編集を行ないます。
WSDL ビュー: WSDL ドキュメントの表示と編集を行ないます。
Authentic ビュー: StyleVision Power Stylesheet をベースにした XML ドキュメントの編集をグラフィカルなインターフェイスで行ないます。
ブラウザビュー: CSS ならびに XSL スタイルシートをサポートする統合されたブラウザビューです。

 

メモ:各ファイル拡張子のデフォルトビューは、「ツール | オプション」ダイアログの、ファイルタブにあるデフォルトビューペインにてカスタマイズすることができます。

 


(C) 2019 Altova GmbH