カスタマイズ

www.altova.com すべてを展開/折りたたむ このトピックを印刷 前のページ 1つ上のレベル 次のページ

ホーム >  ユーザー リファレンス > ツールメニュー >

カスタマイズ

[カスタマイズ] コマンドにより、特定のニーズに対して StyleVision をカスタマイズすることができます。


 

コマンド タブ

カスタマイズ ダイアログの [コマンド] タブでは、個々のコマンドをメニュー バーやツールバーに配置することができます。

 

menu_customize_commands

 

メニュー バーやツールバーへコマンドを追加するには、コマンド タブのコマンド ペイン内にあるコマンドを選択し、選択対象をメニュー バーまたはツールバーへドラッグしてください。コマンドを配置することができる場所には I が表示され、ドロップすることでコマンドがその位置に配置されます。コマンドを配置することができない場所では、X マークが表示されます。コマンドに関連付けられたアイコンが存在する場合、ツールバーにはそのアイコンが表示され、そうでない場合にはテキスト形式のコマンドが作成されます。メニュー バーまたはツールバーへコマンドを追加すると、コマンドを右クリックすることで表示されるメニューから、その外観を変更することができます。

 

メニュー バーやツールバーのアイテムを削除するには、カスタマイズ ダイアログが開かれている状態で削除するアイテムを右クリックし、[削除] を選択してください。

 

メモ:

 

上記のカスタマイズはアプリケーションに対して適用され、StyleVision にてドキュメントが開かれているかどうかにかかわらず適用されます。
StyleVision がインストールされたときの状態にメニューやツールバーをリセットするには、ツールバー タブを選択し、[リセット] または [すべてリセット] ボタンをクリックしてください。

 

ツールバー タブ

[ツールバー] タブでは、特定のツールバーを有効化または無効化して、ツールバー アイテムのテキスト ラベルを表示、メニュー バーやツールバーをインストール時の状態へリセットすることができます。

 

menu_customize_toolbars

 

StyleVision のインターフェイスにはメニュー バーとオプションのツールバー (Authentic、デザイン フィルター、フォーマット、標準、テーブル、目次) が表示されます。

 

各ツールバーはコマンドのグループとして分けることができます。コマンドは、コマンドタブが開かれている状態でツールバーに追加することができます。ツールバーをドラッグすることで、画面上の好きな場所へドッキングすることができるほか、ツールバーのタイトル バーをダブルクリックすることでツールバーのドッキング状態を切り替えることができます。

 

カスタマイズ ダイアログのツールバー タブでは、チェック ボックスをクリックすることで、ツールバーを表示/隠すことができます。ツールバーを (ツールバー タブにて) 選択し、[テキスト ラベルを表示] チェック ボックスをクリックすることで、そのツールバーに含まれているアイテムのテキスト ラベルが表示されます。[リセット] ボタンをクリックすることで、選択されたツールバーを StyleVision がインストールされた際の状態へリセットすることもできます。[すべてリセット] ボタンをクリックすると、すべてのツールバーとメニュー バーがリセットされます。

 

メニューバーに関する注意点

メニューバーにコマンドを追加し、アイテムをメニューバーから削除することができます: 上記のコマンドを参照してください。 StyleVision のインストール時の状態にメニューバーをリセットするには、 カスタマイズ ダイアログのツールバータブ内のメニューバーを選択し、 リセット ボタンをクリックします。 (すべてをリセットする ボタンをクリックするとツールバーをリセットします)。

 

キーボード タブ

[キーボード] タブでは、任意の StyleVision コマンドに対してキーボード ショートカットを定義または変更することができます。

 

menu_customize_keyboard

 

コマンドショートカットをコマンドへ割り当てる

 

1.カテゴリー コンボ ボックスから目的のコマンドがあるカテゴリーを選択します。
2.コマンド リスト ボックスにてショートカットを割り当てるコマンドを選択します。
3.[新規ショートカット キー] 入力フィールドをクリックして、コマンドを起動するためのショートカット キーを押下します。[新規ショートカット キー] 入力フィールドにショートカットが表示されます。入力されたショートカットが他のコマンドへ既に割り当てられている場合、入力フィールドの下にそのコマンド名が表示されます (例えば上のスクリーンショットでは、Ctrl+C が [コピー] コマンドへ既に割り当てられているため、ファイルを開くコマンドへの割り当てを行うことはできません)。入力したショートカット キーを取り消すには、Ctrl、Alt、または Shift キーのいずれかを押下してください。
4.[割り当て] ボタンをクリックすることで、入力されたショートカットがコマンドに対して割り当てられます。ショートカットが [現在のキー] リスト ボックスに表示されます。

 

ショートカットの割り当てを変更 (または削除) する

 

1.削除するショートカットが割り当てられているコマンドを選択します。
2.削除するショートカットを [現在のキー] リスト ボックスにてクリックします。
3.選択可能になった [削除] ボタンをクリックします。

 

キーボード の割り当てをすべてリセットする

 

1.[すべてリセット] ボタンをクリックすることで、インストール時のオリジナル ショートカットへ割り当てがリセットされます。すべてのキーボード割り当てを本当にリセットしても良いかの確認を行うダイアログが表示されます。
2.[はい] をクリックすることで、すべてのショートカット割り当てがリセットされます。

 

設定するアクセラレーター

現在機能は割り当てられていません。

 

メニュー タブ

[メニュー] タブではメイン メニューや (右クリックにより表示される) コンテキスト メニューをカスタマイズすることができます。メニュー バーには、ドキュメントが開かれている時に表示されるデフォルト メニューと SPS ドキュメントが開かれている時に表示される SPS メニューがあります。

 

menu_customize_menu

 

メニューをカスタマイズする

1.カスタマイズするメニュー バーを選択します (スクリーンショットでは SPS メニューが選択されています)。
2.[コマンド] タブをクリックして、目的のコマンドをメニュー バーへドラッグしてください。

 

メニューからコマンドを削除する

1.コマンドまたはコマンドを表すアイコンを右クリックして、
2a.ポップアップ メニューから [削除] オプションを選択します。

または、

2b.メニューからコマンドをドラッグして、マウス ポインターの下にチェック マークが表示された状態でドロップします。.

 

メニューバーをリセットする

1.コンボ ボックスからメニューを選択します。
2.メニュー名の下にある [リセット] ボタンをクリックします。メニュー バーをリセットしてもよいか確認するプロンプトが表示されます。

 

コンテキストメニューをカスタマイズする (右クリックメニュー)

1.コンテキスト メニューのコンボ ボックスから目的のコンテキスト メニューを選択します。
2.[コマンド] タブをクリックして、表示されたコンテキスト メニューへコマンドをドラッグします。

 

 

メニューコンテキストメニューからコマンドを削除する

1.コマンドまたはコマンドを表すアイコンを右クリックして、
2.ポップアップ メニューから [削除] オプションを選択します。または、
3.メニューからコマンドをドラッグして、マウス ポインターの下にチェック マークが表示された状態でドロップします。

 

コンテキスト メニューをリセットする

1.コンテキスト メニューのコンボ ボックスから目的のコンテキスト メニューを選択します。
2.コンテキスト メニュー名の下にある [リセット] ボタンをクリックします。リセットしてもよいか確認するプロンプトが表示されます。

 

コンテキスト メニュー ウィンドウを閉じる

タイトル バーの右側にある閉じるアイコンをクリックするか、
カスタマイズ ダイアログ ボックスの [閉じる] ボタンをクリックしてください。

 

メニューのアニメーション

メニューのアニメーション オプションにより、メニューがクリックされたときの表示方法を指定することができます。メニューのアニメーションにあるドロップダウン リストから、目的のオプションを選択してください。

 

メニューに影をつける

メニューの周りに影をつけたい場合にこのオプションを選択してください。すべてのメニューに影が加えられます。

 

オプション タブ

[オプション] タブでは、ツールバーにあるその他の機能をカスタマイズすることができます。

 

[ツールバーに画面のヒントを表示] オプションを有効にすることで、ツールバー アイテムのヒントが表示されます。画面のヒント オプションには、ショートカットも画面に表示するかを指定するためのサブオプションが与えられています。

 

 

 

 


(C) 2019 Altova GmbH