SPYValidateXSDVersion

www.altova.com このトピックを印刷 前のページ 1つ上のレベル 次のページ

ホーム >  プログラマーの レファレンス > Application API > Enumerations >

SPYValidateXSDVersion

Description

Enumeration values that select what XSD version to use. The XSD version that is selected depends on both (i) the presence/absenceand, if present, the valueof the /xs:schema/@vc:minVersion attribute of the XSD document, and (ii) the value of this enumeration.

 

spyValidateXSDVersion_1_0 selects XSD 1.0 if vc:minVersion is absent, or is present with any value.

spyValidateXSDVersion_1_1 selects XSD 1.1 if vc:minVersion is absent, or is present with any value.

spyValidateXSDVersion_AutoDetect selects XSD 1.1 if vc:minVersion=1.1. If the vc:minVersion attribute is absent, or is present with a value other than 1.1, then XSD 1.0 is selected.

 

 

Possible values

spyValidateXSDVersion_AutoDetect

= 0

spyValidateXSDVersion_1_1

= 1

spyValidateXSDVersion_1_0

= 2

 


(C) 2019 Altova GmbH