ENUMXQueryVersion

www.altova.com このトピックを印刷 前のページ 1つ上のレベル 次のページ

ホーム >  サーバー API: HTTP、COM/.NET、Java > サーバー API レファレンス > 列挙 >

ENUMXQueryVersion

処理のために使用される XQuery バージョンを設定します (実行または検証)。

 

eXQVersion10: XQuery バージョンを XQuery 1.0 に設定します。
eXQVersion30: XQuery バージョンを XQuery 3.0 に設定します。 デフォルトの値です。
eXQVersion31: XQuery バージョンを XQuery 3.1 に設定します。

 

メモ:Java 列挙リテラルは、COM/.NET リテラルとは異なる方法で名前が付けられます。以下を参照してください。

 

COM and .NET

 

eXQVersion10

= 1

eXQVersion30

= 3

eXQVersion31

= 31

 

使用例

 

インターフェイス

プロパティ

IXQuery

EngineVersion

 

Java

public enum ENUMXQueryVersion {

      eVersion10

      eVersion30

      eVersion31 }

 

使用例

 

クラス

メソッド

XQuery

setEngineVersion

 


(C) 2019 Altova GmbH