共通メニューと関数へのアクセス

www.altova.com このトピックを印刷 前のページ 1つ上のレベル 次のページ

ホーム >  Eclipse のための MapForce プラグイン >

共通メニューと関数へのアクセス

Eclipse 内では、下にリストされる Eclipse 固有のバリエーションを除き、スタンドアロンバージョン内と同様に MapForce 機能の同じメニューの多数にアクセスすることができます、これはデフォルトのセットアップですが、  Eclipse からのインターフェイスの基本設定を更にカスタマイズする場合は、  ( MapForce パースペクティブを参照してください)。

 

メモ:コンテキストが関連しない場合、Eclipse 内では、 MapForce メニューグループまたはコマンドの一部が無効化 (または 使用できない)場合があります。例: Eclipse 内でマッピングデザインファイル (.mfd) がアクティブな場合のみ、 「挿入」 メニューを使用することができます。

 

MapForce 標準メニューに関する詳細は、 メニューレファレンスを参照してください。

 

一般的な MapForce コマンド

MapForcein のスタンドアロンエディション内で、マッピングデザインファイルに適用することのできる(「検証」FlowForce Server にデプロイ」「コードの生成」 などの) コマンドは、 「ファイル」 メニュー内で使用することができます。Eclipse 内でこれらのコマンドは MapForce メニュー内または MapForce ツールバーで使用することができます。( MapForce プロジェクトファイルを含む) ファイルを開いたり閉じたりするコマンドは、 Eclipse の 「ファイル」 メニュー で使用することができることに注意してください。

gui_mf_eclipse_toolbar

Eclipse 内の MapForce ツールバー

gui_mf_eclipse_help ツールバーボタンは、MapForce ヘルプファイルを開きます。

 

toolbar_mapforce ツールバーボタンは、  MapForce ファイル固有のコマンドを表示します。このボタンを展開すると、現在 Eclipse エディター上でアクティブなファイルにより決定される使用可能なコマンドが表示されます。例: マッピングデザイン (.mfd) ファイル固有のコマンドは、このようなファイルがでアクティブな場合、 Eclipse エディター内で使用することができます。

 

グローバルリソース

グローバルリソースへアクセスまたはグローバルリソースの管理は、 以下を行います:

 

MapForce toolbar_mapforce ツールバーボタンをクリックして展開し、グローバルリソース をクリックします。
MapForce メニューからグローバルリソースをクリックします。

 

MapForce プロジェクト

MapForce のスタンドアロンのエディションでは、プロジェクト メニューは、マッピング プロジェクト (.mfp) ファイルに適用することのできる複数のコマンドを含んでいます。Eclipse 内では、これらのコマンドは以下のように存在します:

 

プロジェクトを開くまたは閉じるコマンドは、  Eclipse 「ファイル」 メニューから使用することができます。
他のプロジェクト専用のコマンドは、 Eclipse 内でコンテキストコマンドとして使用できます。コンテキストコマンドを表示、MapForce プロジェクト (.mfp) ファイルを作成または開く場合は、プロジェクトを右クリックしてください。

gui_mfp_eclipse

標準 MapForce プロジェクト (.mfp) に加え、Eclipse 内では、"MapForce/Eclipse" の型のプロジェクトも作成することができます。このようなプロジェクトは、2面の特質のため、 MapForce コードの自動的なビルドと生成のために構成することができます。マッピングおよびプロジェクトと作業を参照してください.

 

MapForce オプション

MapForce オプションは、 「ウィンドウ | 優先」 メニューから使用することができます。優先ダイアログボックスで、 MapForce を選択し、 「MapForce オプションダイアログを開く」 をクリックします。

mf_eclipse_options_zoom25

設定ダイアログボックス

 

ライブラリウィンドウ

Eclipse 内で、 MapForce ライブラリウィンドウは、ビューとして使用することができます。このビューはデフォルトでは、メインエディターウィンドウの左に配置されています。 (MapForce に関連したすべてのビューは、 MapForce パースペクティブ がオンに切り替えられると、 Eclipse インターフェイス で表示されます MapForce パースペクティブも参照)。

 

MapForce プラグイン バージョン

Eclipse のための MapForce プラグインの現在インストールされているバージョンを確認するには、 Eclipse メニューオプション ヘルプ | Eclipse プラットフォームについて」 を選択して、 そして、MapForce アイコンを選択します。

 

ヘルプとサポート

MapForce ヘルプ、サポートセンター、最新情報 メニュー は、 Eclipse の 「ヘルプ | MapForce ヘルプ」 メニューで使用することができます。


(C) 2019 Altova GmbH