依存しないブラウザー

www.altova.com このトピックを印刷 前のページ 1つ上のレベル 次のページ

ホーム >  サーバーのセットアップ > Authentic プラグインのための HTML ページ >

依存しないブラウザー

プロジェクトの一部では、どのブラウザー (Internet Explorer または Firefox) がクライアント上で使用されるか未知の場合があります。 このような場合、 Internet Explorer と Firefox のための Authentic Browser バージョン をサーバー上に保管することができます (すなわち、 CAB ファイルと XPI ファイルがサーバー上に保管されることを意味します)。HTML ページ内では、  HTML ページを開くために使用されたブラウザーを決定するスクリプトを挿入することができ、ロードする正確な Authentic Browser プラグインが選択されます。

 

更に、 クライアント上で Internet Explorer がブラウザーとして使用されている場合、 正確な .CAB ファイル ( 32-ビット、または、64-ビット Internet Explorer) が選択されサーバーからダウンロードされる必要があります。 スクリプトは、Internet Explorer は X-ビットバージョンのためにテストされ、サーバーからダウンロードされる正確な .CAB ファイルを選択します。

 

このセクションには次を行う、サンプル ファイル が含まれています: ブラウザーを決定し、正確な Authentic Browser バージョンをロードし、いくつかの機能を実行します。

 

個別のオブジェクトに関する情報に関しては、レファレンスセクション内の対応するオブジェクトの説明を参照してください。

 

メモ:

 

Authentic Browser プラグインは Internet Explorer 5.5 または以降、 Mozilla Firefox のためにサポートされています。
Firefox 使用法に関しては、XPI ファイルのための MIME の種類がサーバー上の使用するサイトのための MIME の種類のリスト ブラウザーサービスに追加され ます。

 


(C) 2019 Altova GmbH