Différences avec XMLSpy Standalone

www.altova.com Imprimer cette rubrique Page précédente Un niveau supérieur Page suivante

Accueil >  Manuel de l'utilisateur et référence > XMLSpy dans Visual Studio >

Différences avec XMLSpy Standalone

Cette section recense les différences entre les versions de Visual Studio et les versions standalone de XMLSpy. La liste commence avec des fonctions qui ne sont pas prises en charge dans la version de Visual Studio et poursuit avec une liste des autres différences entre la version Visual Studio et la version standalone.

 

Fonctions non prises en charge dans Visual Studio
Menus XMLSpy supplémentaires dans Visual Studio
Assistants à la saisie dans Visual Studio
Même fonction, commande différente
Commandes XMLSpy en tant que commandes Visual Studio

 

Fonctions non prises en charge dans Visual Studio

Les fonctions XMLSpy suivantes ne sont pas disponibles dans Visual Studio :

 

L'environnement Scripting (Tools | Options XMLSpy | Script) n'est pas pris en charge actuellement.
Fenêtre de navigateur séparée (une option dans la section Tools | Options | View) n'est pas prise en charge. Cela signifie que les Modes Texte et Navigateur sont toujours dans la même fenêtre.
Les icônes d'état de texte de Authentic View ne sont pas prises en charge.
Toutes les fonctions de Contrôle de Source.
Toutes les fonctions de comparaison (disponibles dans le menu Tools de la version standalone).

 

Menus XMLSpy supplémentaires dans Visual Studio

Les commandes suivantes sont spécifiques à XMLSpy dans Visual Studio :

 

View | Fenêtre Outils XMLSpy
View | XMLSpy View
XMLSpy (comprend les items de menu Ressources Globales)
Tools | Options XMLSpy

 

Assistants à la saisie  (fenêtres Outil dans Visual Studio)

Les assistants à la saisie de XMLSpy sont disponibles en tant que fenêtres Outils dans Visual Studio. Veuillez noter les points suivants. (Pour une description des assistants à la saisie et de la GUI XMLSpy, voir la section, Introduction.)

 

Vous pouvez glisser les fenêtres des assistants à la saisie dans n'importe quelle position dans l'environnement de développement.
Cliquer avec la touche de droite sur un onglet d'assistant à la saisie pour une personnalisation plus poussée de votre interface. Les options de configuration des assistants à la saisie sont : ancrage, dissimulation, flottant et dissimulation automatique.

 

Même fonction, commande différente

Certaines fonctions de XMLSpy sont disponibles dans Visual Studio sous des commandes nommées différemment :

 

XMLSpy

Visual Studio

Fonction

Fichier | Ouvrir | Passer à l'URL

File | Open | Website

(Fichier | Ouvrir | Site web)

Ouvre le fichier depuis l'URL

Passer à l'URL | Enregistrer

File | Save XMLSpy File to URL

(Fichier | Enregistrer le fichier XMLSpy dans l'URL)

Enregistre le fichier dans l'URL

 

Commandes XMLSpy en tant que commandes Visual Studio

Certaines commandes XMLSpy sont présentes en tant que commandes Visual Studio dans la GUI Visual Studio :

 

Undo, Redo (Annuler, Rétablir) : Ces commandes Visual Studio touchent toutes les actions dans l'environnement de développement Visual Studio.
Projects (Projets) : XMLSpy projects are handled as Visual Studio projects.
Customize Toolbars, Customize Commands (Personnaliser les barres outils, Personnaliser les commandes) : Les onglets Barres outils et Commandes (capture d'écran ci-dessous) dans le dialogue Customize (Personnaliser) (Tools | Customize) (Outils | Personnaliser) contient aussi bien les commandes Visual Studio que les commandes XMLSpy.

net-cust-keyb

Views: dans le menu View, les deux commandes Fenêtre Outils XMLSpy et Mode XMLSpy, contiennent des options pour activer et désactiver les fenêtres d'assistants à la saisie et d'autres barres latérales, pour passer entre les modes d'édition et pour  et désactiver certains guides d'édition.
Aide XMLSpy : Ce menu XMLSpy apparaît en tant que sous-menu dans le menu Help de Visual Studio.

 


© 2018 Altova GmbH