Créer le Schéma XML depuis la structure BD

www.altova.com Imprimer cette rubrique Page précédente Un niveau supérieur Page suivante

Accueil >  Manuel de l'utilisateur et référence > Commandes de menu  > Menu Conversion >

Créer le Schéma XML depuis la structure BD

ic_conv_create_schema_from_db

La commande Créer Schéma XML depuis la structure de BD vous permet de créer un Schéma XML depuis la structure d'un grand nombre de bases de données. Le mécanisme de création de Schéma XML comprend deux étapes :

 

1.Une connexion à la base de données est établie.
2.Des options pour la sélection de données de base de données et pour le Schéma XML sont spécifiées.

 

Pour créer un Schéma XML depuis une structure BD vous pouvez suivre les étapes suivantes :

 

1.Lorsque vous cliquez sur la commande Créer Schéma XML depuis la Structure BD, la fenêtre de l'assistant de connexion à la base de données apparaît.
2.L'assistant à la connexion à la base de données, vous permet d'établir une connexion à la base de données (pour plus d'instructions, voir Connexion à une base de données).
3.Une fois que la connexion à la base de données est établie, le dialogue Créer Schéma XML depuis la structure BD (capture d'écran ci-dessous) affiche les onglets et les fenêtres qui vous permettent de sélectionner la structure de la base de donnés à importer. Ces options sont décrites ci-dessous. Une fois avoir terminé, cliquer sur la touche Importer pour importer les données de base de données.

URefConvert_ImportDB2Schema

 

Onglet Sélection

Dans l'onglet Sélection (capture d'écran ci-dessous), la source de données est listée dans le volet Source. Celui-ci affiche soit une représentation des tables de la base de données soit une déclaration SQL éditable pour sélectionner les tables requises.

URefConvert_ImportDB2XSDSelection

Dans l'aperçu Table, vous pouvez sélectionner les tables dans la base de données que vous souhaitez importer en cochant la case de la table (capture d'écran ci-dessus). Les contenus de la table peuvent ensuite être affichés dans le volez Aperçu. La sélection de la table peut aussi être filtrée dans le volet Aperçu (voir ci-dessous). Vous pouvez configurer l'affichage dans le volet Source tel que décrit dans la section Importer Données de base de données.

 

Onglet Options

Dans l'onglet Options (capture d'écran ci-dessous), vous pouvez spécifier le format du schéma, son type d'extension, si les colonnes doivent être importées en tant qu'éléments ou attributs, et les contraintes de base de données qui doivent être générées dans le schéma.

URefConvert_ImportDB2XSDOptions

Format de schéma : vous pouvez sélectionner entre un format de schéma plat (SQL/XML Standard) et hiérarchique

 

Le modèle de schéma flat est basé sur une spécification ISO-ANSI SQL/XML INCITS/ISO/IEC 9075-14-2008. La spécification SQL/XML définit comment mapper les bases de données en XML. Les relations sont définies dans les schémas en utilisant des contraintes d'identité ; il n'y a pas de références aux éléments. Ainsi, le schéma présente une structure plate qui ressemble à un aperçu arborescent de la base de données. La spécification peut être achetée dans la boutique ANSI. Pour plus d'informations, voir www.iso.org.
Le modèle de schéma hiérarchique affiche les dépendances de table visuellement, dans un type d'aperçu arborescent où des tables dépendantes sont affichées en tant qu'éléments enfants indentés dans le modèle de contenu. Les dépendances de table sont aussi affichées dans l'onglet Contraintes d'identité.

Les tables sont listées en tant qu'éléments globaux dans le schéma, et les colonnes sont les éléments ou les attributs de ces éléments globaux (l'utilisateur décide s'il veut mapper les colonnes en tant qu'éléments ou en tant qu'attributs). Les relations sont créées de manière hiérarchiques de manière à ce qu'un champ de clé étrangère dans une table constitue effectivement une référence à l'élément global qui représente la table.

 

Type d'extension de schéma : l'information d'extension de schéma est une information supplémentaire lue depuis une base de données qui est ensuite intégrée dans le schéma soit en tant que données d'annotation soit en tant qu'attributs. Il existe quatre types d'options d'extension lors de la génération de schémas : (i) aucune information d'extension ; (ii) extensions SQL/XML ; (iii) extensions serveur SQL MS ; et (iv) extensions Oracle. Celles-ci sont décrites ci-dessous :

 

Aucun : aucune information supplémentaire est fournie par la base de données.
SQL XML : les extensions SQL/XML sont uniquement insérées lors de la génération des schémas dans un format plat. L'information d'extension est stockée dans les annotations et est décrite dans la spécification SQL/XML (INCITS/ISO/IEC 9075-14-2008).
Serveur MS SQL : la sélection du serveur SQL Microsoft, génère des extensions de serveur SQL. Voir SQL Server Books Online pour les ressources et l'information  de MSDN à propos de l'annotation des schémas XSD. Les éléments liés à l'annotation suivants sont générés dans le schéma: sql:relation, sql:field, sql:datatype, sql:mapped.
Oracle : les extensions Oracle sont sélectionnées par défaut lors du travail avec une base de données Oracle. Une information de base de données supplémentaire est stockée en tant qu'attributs. L'information détaillée peut être trouvée dans la documentation en ligne d'Oracle. Les sous-ensembles suivants des attributs sont générés actuellement : SQLName, SQLType, SQLSchema.

 

Note :Bien que les extensions SQL Server et Oracle peuvent être générées pour leurs bases de données respectives, elles ne sont pas limitées. Cela peut être utile lors du travail avec une troisième base de données et si vous souhaitez générer un schéma capable de travailler plus tard soit avec le serveur SQL ou Oracle.

 

Volet Aperçu

Le volet Aperçu (capture d'écran ci-dessous) affiche la structure de la table actuellement sélectionnée dans l'onglet Sélection. Lorsqu'une nouvelle table est sélectionnée dans l'onglet Sélection, cliquer sur la touche Recharger dans le volet Aperçu pour réinitialiser l'aperçu.

URefConvert_ImportDBDataPreview

Un champ peut être spécifié pour être importé en tant qu'un élément ou un attribut, ou pour ne pas être importé, en cliquant sur le symbole à gauche du nom de la colonne. Vous pouvez cliquer sur dans les options élément, attribut et ignorer. Dans la capture d'écran ci-dessous, le champ city, par exemple, a été configuré pour être importé en tant qu'un élément, alors que le champ street a été configuré pour être importé en tant qu'un attribut.

 

Conversions de type de données

Vous trouverez des informations concernant la conversion des types de données de base de données en types de données Schéma XML dans les Annexes.

 


© 2018 Altova GmbH