Installation sur Linux

www.altova.com Agrandir/Réduire tout Imprimer cette rubrique Page précédente Un niveau supérieur Page suivante

Accueil >  Configuration sur Linux >

Installation sur Linux

MapForce Server est disponible pour une installation sur les systèmes Linux. La procédure d'installation et de configuration est décrite ci-dessous.

 

Click to expand/collapseExigences du système
CentOS 6 ou plus récent
RedHat 6 ou plus récent
Debian 8 ou plus récent
Ubuntu 14.04 ou plus récent

 

Les bibliothèques suivantes sont exigées en tant que condition préalable pour installer et exécuter l'application. Si les paquets ci-dessous ne sont pas encore disponibles sur votre appareil Linux, vous pourrez exécuter la commande command yum (ou apt-get le cas échéant) pour les installer.

 

Exigé par

CentOS, RedHat

Debian

Ubuntu

LicenseServer

krb5-libs

libgssapi-krb5-2

libgssapi-krb5-2

MapForce Server

libidn, krb5-libs

libidn11, libgssapi-krb5-2

libidn11, libgssapi-krb5-2

 

 

Click to expand/collapse Intégration du serveur FlowForce

Si vous installez MapForce Server avec FlowForce Server, il est recommandé d'installer FlowForce Server d'abord. Sinon, après avoir installé MapForce Server et FlowForce Server, exécuter la commande suivante :

 

cp /opt/Altova/MapForceServer2019/etc/*.tool /opt/Altova/FlowForceServer2019/tools

 

Cette commande copie le fichier .tool depuis le répertoire /etc de MapForce Server vers le répertoire /tools de FlowForce Server. Le fichier .tool est nécessité par FlowForce Server. Il contient le chemin vers le programme exécutable MapForce Server. Si vous installez FlowForce Server avant d'installer MapForce Server, vous n'aurez pas besoin d'exécuter cette commande.

 

 

Click to expand/collapseDésinstaller les anciennes versions des produits de serveurs Altova

Suivez les étapes suivantes pour procéder à une désinstallation. Dans l'interface de ligne de commande Linux (CLI), vous pouvez vérifier quels sont les produits de serveur Altova installés avec les commandes suivantes :

[Debian, Ubuntu]:   dpkg --list | grep Altova

[CentOS, RedHat]:   rpm -qa | grep server

 

Si MapForce Server n'est pas installé, poursuivez l'installation comme documenté ci-dessous dans Installer MapForce Server.

 

Si MapForce Server est installé et vous souhaitez installer une version plus récente de MapForce Server, désinstaller l'ancienne version avec la commande ::

[Debian, Ubuntu]:   sudo dpkg --remove mapforcecserver

[CentOS, RedHat]:   sudo rpm -e mapforceserver

 

Si vous devez désinstaller une ancienne version de Altova LicenseServer, procédez comme suit :

[Debian, Ubuntu]:   sudo dpkg --remove licenseserver

[CentOS, RedHat]:   sudo rpm -e licenseserver

 

 

Click to expand/collapseTélécharger le paquet Linux

Les paquets d'installation MapForce Server pour les systèmes Linux suivants sont disponibles sur le site web Altova .

 

Distribution

Extension du paquet

Debian

.deb

Ubuntu

.deb

CentOS

.rpm

RedHat

.rpm

 

Après le téléchargement du paquet Linux, le copier dans un répertoire du système Linux. Puisqu'il vous faudra Altova LicenseServer pour pouvoir exécuter MapForce Server, vous pouvez éventuellement télécharger LicenseServer depuis le site web Altova au moment de télécharger MapForce Server, au lieu de le télécharger plus tard.

 

 

Click to expand/collapseInstaller MapForce Server

Dans une fenêtre de terminal, passez au répertoire dans lequel vous avez copié le paquet Linux. Par exemple, si vous l'avez copié dans un répertoire d'utilisateur appelé MyAltova (situé par exemple dans le répertoire /home/User), passez à ce répertoire comme suit :

cd /home/User/MyAltova

 

Installer MapForce Server avec la commande suivante :

 

[Debian]:   sudo dpkg --install mapforceserver-2019-debian.deb

[Ubuntu]:   sudo dpkg --install mapforceserver-2019-ubuntu.deb

[CentOS]:   sudo rpm -ivh mapforceserver-2019-1.x86_64.rpm

[RedHat]:   sudo rpm -ivh mapforceserver-2019-1.x86_64.rpm

 

Note :Vous devrez éventuellement ajuster le nom du pack ci-dessus pour correspondre à la release actuelle ou à la version de pack de service.

 

Le paquet MapForce Server sera installé dans le dossier :

/opt/Altova/MapForceServer2019

 

 

Click to expand/collapseAltova LicenseServer

Pour faire fonctionner tout produit Altova Server, y compris MapForce Server, ce produit de serveur doit posséder une licence via Altova LicenseServer sur votre réseau.

 

Sur des systèmes Linux, Altova LicenseServer devra être installé séparément. Télécharger LicenseServer depuis le site web Altova et copier le paquet dans un répertoire sur le système Linux. L'installer de la même manière que MapForce Server (voir étape précédente).

[Debian]:   sudo dpkg --install licenseserver-3.2-debian.deb

[Ubuntu]:   sudo dpkg --install licenseserver-3.2-ubuntu.deb

[CentOS]:   sudo rpm -ivh licenseserver-3.2-1.x86_64.rpm

[RedHat]:   sudo rpm -ivh licenseserver-3.2-1.x86_64.rpm

 

Le paquet LicenseServer sera installé dans :

/opt/Altova/LicenseServer

 

Pour plus d'informations concernant l'enregistrement de MapForce Server avec Altova LicenseServer et l'obtention d'une licence, voir la section, Obtention de la licence sur Linux. Voir aussi la documentation LicenseServer pour plus de détails

 

 

Click to expand/collapseVersions de LicenseServer
Une licence doit être délivrée pour les produits de serveur Altova, soit avec la version LicenseServer convenant à la version du MapForce Server installée, soit avec une version ultérieure de LicenseServer.
La version LicenseServer qui convient pour une version particulière de MapForce Server est affichée pendant l'installation de MapForce Server. Vous pouvez installer cette version de LicenseServer avec MapForce Server, ou bien vous pouvez installer LicenseServer séparément.
Avant d'installer une version plus récente de LicenseServer, toute version plus ancienne doit être désinstallée. Le programme d'installation LicenseServer effectuera cette procédure automatiquement si elle détecte une version plus ancienne.
Les versions LicenseServer sont rétrocompatibles. Elles fonctionneront avec des versions plus anciennes de MapForce Server.
Si vous installez une nouvelle version de MapForce Server et si votre version installée de LicenseServer est plus ancienne que le LicenseServer approprié, installer la dernière version disponible du site web Altova.
Au moment de la désinstallation de LicenseServer, toutes les informations d'enregistrement et d'obtention de la licence contenues dans la version plus ancienne de LicenseServer seront enregistrées dans une base de données sur la machine de votre serveur. Ces données seront importées automatiquement dans la version la plus récente lorsque la version la plus récente est installée.
Le numéro de version du LicenseServer actuellement installé est indiqué au bas de la page de configuration de LicenseServer (tous les onglets).

 

Version actuelle : 3.2

 

 


© 2019 Altova GmbH