Versión 2014

www.altova.com Imprimir este apartado Página anterior Subir un nivel Página siguiente

Inicio >  Guía y referencia del usuario > Novedades 2019 >

Versión 2014

Versión 2014 Release 2

Novedades de la versión 2014r2 de XMLSpy.

 

Nuevas funciones de extensión de Altova para XSLT y XPath/XQuery.
Opción para agregar mensajes para aserciones de XML Schema 1.1. Si un documento XML no es válido porque la prueba de aserción da un resultado negativo, puede usar estos mensajes para explicar por qué el documento no es válido.

 

Versión 2014

Novedades de la versión 2014 de XMLSpy.

 

Los motores XSLT 3.0 y XQuery 3.0 se incluyen en la versión 2014 de XMLSpy (compatible con funciones XPath y XQuery 3.0). Las características de edición inteligente, validación y transformación/ejecución para XSLT 3.0, XQuery 3.0 y funciones XPath y XQuery 3.0 también están disponible en las características relacionadas con XSLT, XQuery y funciones XPath/XQuery.
La característica de evaluación de expresiones XPath en la ventana XPath ya es compatible con XPath 3.0.
Compatibilidad con XML Schema (XSD) 1.1: edición inteligente y validación de documentos XSD 1.1 en la vista Esquema.
Se puede especificar un límite de errores definido por el usuario para la validación de esquemas XML. Esto es muy práctico porque reduce el tiempo de validación y permite corregir los errores por tandas.
Mejoras en la función de conversión de documentos DTD en esquemas XML y viceversa. Los documentos DTD y esquemas XML también se pueden nivelar. El proceso de nivelación consiste en guardar los archivos incluidos e importados en el archivo primario directamente.
Mejoras en la función de generación de documentos XML de muestra a partir de esquemas XML: los elementos de una rama concreta de los grupos choice se pueden seleccionar para el documento de muestra.
En la ventana Esquema XSL puede seleccionar el modo de la transformación se puede seleccionar de forma gráfica en un cuadro combinado.
Integración en Eclipse 4.3: XMLSpy ofrece compatibilidad con la última versión de la plataforma Eclipse, además de con las versiones 3.8 y 4.2. XMLSpy ya no es compatible con las versiones antiguas Eclipse 3.6 y 3.7.

 


© 2019 Altova GmbH