Diferencias entre XMLSpy y XMLSpy para Visual Studio

www.altova.com Imprimir este apartado Página anterior Subir un nivel Página siguiente

Inicio >  Guía y referencia del usuario > XMLSpy en Visual Studio >

Diferencias entre XMLSpy y XMLSpy para Visual Studio

Este apartado enumera las diferencias entre el complemento de XMLSpy para Visual Studio y la versión independiente de XMLSpy. Primero describimos las funciones que no están disponibles en la versión de XMLSpy para Visual Studio y después explicamos las diferencias entre las dos versiones.

 

Funciones no disponibles en el complemento de XMLSpy para Visual Studio
Menús adicionales de XMLSpy en Visual Studio
Ayudantes de entrada en Visual Studio
Funciones idénticas, comandos distintos
Comandos de XMLSpy como comandos de Visual Studio

 

Funciones no disponibles en el complemento de XMLSpy para Visual Studio

Estas funciones de XMLSpy no están disponibles en la versión para Visual Studio:

 

El entorno de scripting no está disponible por ahora (Herramientas | Opciones de XMLSpy | Scripting).
No puede abrir archivos en una ventana separada del explorador (opción de Herramientas | Opciones | Vista). Esto significa que la vista Texto y la vista Explorador están siempre en la misma ventana.
Los iconos de estado de texto de la vista Authentic.
Ninguna de las funciones de control de código fuente.
Ninguna función de comparación (disponibles en el menú Herramientas de la versión independiente de XMLSpy).

 

Menús adicionales de XMLSpy en Visual Studio

Estos comandos aparecen sólo en la versión de XMLSpy para Visual Studio:

 

Ver | Ventanas de herramientas de XMLSpy
Ver | Vista XMLSpy
XMLSpy (incluye las opciones de menú de Recursos globales)
Herramientas | Opciones de XMLSpy

 

Ayudantes de entrada (Ventanas de herramientas en Visual Studio)

Los ayudantes de entrada de XMLSpy se llaman Ventanas de herramientas en Visual Studio. Es necesario tener en cuenta estos aspectos:

 

Puede arrastrar las ventanas de los ayudantes de entrada y colocarlas en cualquier posición del entorno de desarrollo.
Puede seguir personalizando la interfaz si hace clic con el botón derecho en una pestaña de un ayudante de entrada. El menú contextual que aparece incluye opciones para acoplar la ventana, ocultarla, ocultarla automáticamente o hacerla flotante.

 

Nota: para más información sobre los ayudantes de entrada de XMLSpy consulte la sección Introducción.

 

Funciones idénticas, comandos distintos

Algunas funciones de XMLSpy están disponibles en Visual Studio pero el comando utilizado para acceder a ellas se llama de otra manera. Se trata de estas funciones:

 

XMLSpy

Visual Studio

Función

Archivo | Abrir | Cambiar a URL

Archivo | Abrir | Sitio web

Abre un archivo desde una URL

Cambiar a URL | Guardar

Archivo | Guardar el archivo de XMLSpy en una URL

Guarda el archivo en una URL

 

Comandos de XMLSpy como comandos de Visual Studio

Algunos comandos de XMLSpy son comandos de Visual Studio en la interfaz de Visual Studio. Se trata de estos comandos:

 

Deshacer/Rehacer: estos comandos de Visual Studio afectan a todas las acciones realizadas en el entorno de Visual Studio.
Proyectos: los proyectos de XMLSpy se consideran proyectos de Visual Studio.
Personalizar las barras de herramientas/Personalizar los comandos: las pestañas Barras de herramientas y Comandos (ver imagen siguiente) del cuadro de diálogo Personalizar (Herramientas | Personalizar) incluye tanto los comandos de Visual Studio como los de XMLSpy.

net-cust-keyb

Vistas: en el menú Ver los comandos Ventanas de herramientas de XMLSpy y Vista XMLSpy incluyen opciones para activar/desactivar las ventanas de los ayudantes de entrada y otras barras laterales, para cambiar de vista de edición y para activar/desactivar determinadas guías de edición.
Ayuda de XMLSpy: este menú de XMLSpy es un submenú del menú Ayuda de Visual Studio.

 

Nota:las imágenes y capturas de pantalla de esta sección son de Visual Studio 2010. Si utiliza otra versión de Visual Studio, puede que encuentre diferencias entre estas imágenes y su versión.

 


© 2019 Altova GmbH