Puntos de entrada de XMLSpy en Eclipse

www.altova.com Imprimir este apartado Página anterior Subir un nivel Página siguiente

Inicio >  Guía y referencia del usuario > XMLSpy en Eclipse >

Puntos de entrada de XMLSpy en Eclipse

Para acceder a las funciones de XMLSpy puede usar estos puntos de entrada en Eclipse:

 

Perspectiva XMLSpy, que ofrece las funciones de la interfaz de XMLSpy dentro de la interfaz de Eclipse.
Barra de herramientas y menú XMLSpy

 

En Eclipse una perspectiva es una vista de la interfaz del usuario configurada con función de operador. Cuando el complemento de XMLSpy está integrado en Eclipse, se crea automáticamente una perspectiva XMLSpy predeterminada. Esta perspectiva es una interfaz gráfica del usuario que incluye los elementos de la interfaz de XMLSpy: sus vistas de edición, menús, ayudantes de entrada y otras barras laterales.

 

Al abrir un tipo de archivo asociado a XMLSpy  (por ejemplo, .xml), el archivo se puede editar en la perspectiva XMLSpy. También puede abrir archivos de otro tipo en otra perspectiva de Eclipse. Además, puede cambiar de perspectiva en todo momento, lo cual permite editar o procesar el archivo en otro entorno. Por tanto, las perspectivas tienen dos ventajas:

 

1.Permiten cambiar el entorno de trabajo para el archivo activo
2.Y permiten cambiar de un archivo a otro sin necesidad de abrir un entorno de desarrollo nuevo (el entorno asociado está disponible en la perspectiva)

 

Para trabajar con la perspectiva XMLSpy es necesario:

 

Cambiar a la perspectiva XMLSpy.
Configurar las preferencias de la perspectiva XMLSpy.
Personalizar la perspectiva XMLSpy.

 

 

Cambiar a la perspectiva XMLSpy

En Eclipse seleccione el comando Window | Open Perspective | Other. En el diálogo que aparece (imagen siguiente) seleccione XMLSpy y haga clic en OK.

 

inc-EclipseOpenPerspectives

 

La ventana vacía o el documento activo tendrán ahora la perspectiva XMLSpy. Así es como se cambia de perspectiva desde el menú. Para cambiar más rápido de una perspectiva a otra se puede incluir la perspectiva deseada en el submenú Open Perspective, sobre la opción Other. Esto se hace en el cuadro de diálogo de personalización.

 

También puede cambiar de perspectiva al abrir un archivo o activar un archivo. La perspectiva asociada al tipo de archivo se abre automáticamente al abrir el archivo por primera vez. Antes de que cambie la perspectiva, aparece un cuadro de diálogo donde debe indicar si desea abrir automáticamente la perspectiva asociada a este tipo de archivo..

 

Marque la casilla Do Not Ask Again (No volver a preguntar) si desea asociar la perspectiva a ese tipo de archivo sin tener que confirmarlo cada vez que abra un archivo de este tipo. Después haga clic en OK.

 

 

Configurar las preferencias de la perspectiva XMLSpy

Las preferencias de una perspectiva incluyen: (i) una opción para cambiar automáticamente de perspectiva al abrir un archivo de un tipo determinado (ver párrafo anterior) y (ii) opciones para incluir o excluir algunas barras de herramientas de XMLSpy. Para abrir el cuadro de diálogo de preferencias, seleccione el comando Window | Preferences.

 

En la lista de perspectivas del panel de la izquierda, seleccione XMLSpy y después las opciones que desea usar. Para terminar haga clic en OK.

 

 

Personalizar la perspectiva XMLSpy

En Eclipse puede configurar qué accesos directos y comandos aparecen en cada perspectiva. Para abrir el cuadro de diálogo para personalizar la perspectiva (imagen siguiente), active la perspectiva que desea personalizar (en este caso la perspectiva XMLSpy) y seleccione el comando Window | Customize Perspective.

 

Clic para expandir/contraer

 

En la pestaña Commands puede agregar grupos de comandos a menús primarios y a la barra de herramientas. Si desea habilitar un grupo de comandos, marque la casilla del grupo.

 

En la pestaña Shortcuts puede definir accesos directos para los submenús. Seleccione el submenú en el cuadro combinado Submenus, después seleccione una categoría de accesos directos y por último seleccione los accesos directos que desea incluir en la perspectiva.

 

Haga clic en OK para terminar de personalizar la perspectiva.

 

XMLSpy menu and toolbar

El menú de XMLSpy contiene comandos relevantes incluso cuando el tipo de documento que reconoce XMLSpy no se puede abrir en Eclipse. Algunos de estos comandos aparecen en el menú Archivo de la versión independiente de XMLSpy.

 

La barra de herramientas de XMLSpy contiene estos botones:

 

inc-EclipseTBButtonsXS

 

Estos comandos sirven para (i) abrir la Ayuda de XMLSpy y (ii) acceder a los comandos de XMLSpy (aunque también puede acceder a ellos desde el menú XMLSpy)

 

Formatos de archivo de XMLSpy y comportamiento de las vistas Eclipse

Cuando en Eclipse están activos determinados tipos de archivos conocidos por XMLSpy, aparecen las vistas Elementos, Atributos y Entidades adaptadas al tipo de archivo activo. Por ejemplo, si el archivo activo es un archivo .css, la vista Elementos pasa a llamarse Esquema CSS. En esta tabla puede ver las correspondencias entre el tipo de archivo y el nombre que toman las vistas:

 

Si el formato del archivo activo es...

La vista Elementos pasa a llamarse...

La vista Atributos pasa a llamarse...

La vista Entidades pasa a llamarse...

.css

Esquema CSS

Propiedades CSS

Elementos HTML

.xquery, .xq

Palabras clave XQuery

Variables XQuery

Funciones XQuery

.xsd

Componentes

Detalles

Facetas

 

Si cierra una de estas vistas, puede volver a restaurarla con el comando de menú Window | Show | View de Eclipse. Sin embargo, recuerde que las vistas aparecen en este menú con su nombre genérico (es decir, Elementos, Atributos y Entidades). Por ejemplo, si cierra la vista Esquema CSS, cuando intente restaurarla desde el menú Window | Show deberá seleccionar la vista Elementos (Show | View | Elementos).

 

Otra manera de restaurar la vista es restaurar los valores predeterminados de la perspectiva XMLSpy con el comando Window | Reset Perspective.

 


© 2019 Altova GmbH