Introducción

www.altova.com Expandir/Contraer todos Imprimir este apartado Subir un nivel Página siguiente

Inicio > 

Introducción

Altova StyleVision Server es una implementación del motor de ejecución integrado de StyleVision. Funciona como módulo de FlowForce Server y también está disponible como producto servidor independiente.

 

StyleVision Server ejecuta paquetes de transformación implementados en FlowForce Server. FlowForce Server inicia estas transformaciones en base a desencadenadores temporizados programables, desencadenadores de archivos o desencadenadores remotos. Además las funciones de StyleVision Server se pueden invocar desde la línea de comandos.

 

 

Requisitos del sistema, instalación y asignación de licencias

StyleVision Server es compatible con estos sistemas operativos:

 

hmtoggle_arrow1Windows

Windows 7 SP1 con actualización de la plataforma, Windows 8, Windows 10

 

hmtoggle_arrow1Windows Server

Windows Server 2008 R2 SP1 con actualización de la plataforma o superior

 

 

hmtoggle_arrow1Linux
CentOS 6 o superior
RedHat 6 o superior
Debian 8 o superior
Ubuntu 14.04 o superior

 

Las bibliotecas que aparecen a continuación son un requisito previo para la instalación y ejecución de la aplicación. Si los paquetes que aparecen en esta tabla no están en su equipo Linux, ejecute el comando yum (o apt-get si procede) para instalarlos.

 

Requisito para

CentOS, RedHat

Debian

Ubuntu

LicenseServer

krb5-libs

libgssapi-krb5-2

libgssapi-krb5-2

StyleVision Server

qt4, krb5-libs, qt-x11

libqtcore4, libqtgui4, libgssapi-krb5-2

libqtcore4, libqtgui4, libgssapi-krb5-2

 

Nota: si quiere usar la función de gráficos de Altova, entonces debe haber al menos una fuente instalada en su sistema para que los gráficos se muestren correctamente. Para ver una lista de las fuentes instaladas use, por ejemplo, el comando fc-list de la Fontconfig library.

 

Nota: en el servidor Ubuntu 18.04.1 LTS es necesario habilitar el apt del repositorio universe (con el comando sudo add-apt-repository universe). Tras esta actualización se puede instalar libqtgui4.

 

 

hmtoggle_arrow0macOS

macOS 10.12 o superior

 

 

 

Además Altova ofrece versiones de 32 y 64 bits de StyleVision Server.

 

Para más información sobre cómo instalar StyleVision Server y asignarle licencias, consulte los apartados sobre la instalación en Windows, Linux y macOS.

 

Clic para expandir/contraerDirectiva SOP (Same-Origin Policy) de Google Chrome

Cuando visualice la ayuda que viene con los productos servidor de Altova en el explorador Google Chrome, (i) puede que le sea imposible contraer la tabla de contenido que está expandida en la parte izquierda de la página y (ii) puede que no pueda ampliar las imágenes en miniatura al hacer clic en ellas. Estas limitaciones se deben a las restricciones de la directiva SOP (Same-Origin Policy) que aplica Chrome. Si se encuentra con estos problemas, tiene varias opciones:

 

Deshabilite la directiva SOP de Chrome. Para ello debe abrir Chrome desde la línea de comandos con el argumento --disable-web-security. (Si tras reiniciar Chrome con esta opción de seguridad web deshabilitada, cierra el explorador y lo reinicia normalmente (es decir, sin el argumento), Chrome se reiniciará con la opción de seguridad web habilitada. Sin embargo, debe tener en cuenta que este argumento deshabilita la seguridad web del explorador y pone en peligro la seguridad de su organización. En otras palabras, se trata de una solución arriesgada y, por tanto, no recomendada.
Utilice un explorador web con una directiva SOP que permita (i) contraer y expandir elementos de las tablas de contenidos (p. ej. Firefox) y (ii) expandir las imágenes en miniatura (p. ej. Firefox).
Utilice Chrome a pesar de las restricciones de la directiva SOP. Aparte de los problemas aquí mencionados, la ayuda funcionará perfectamente.

 

 

Última actualización: 10/05/2019

 


© 2019 Altova GmbH