Editor de diseños

www.altova.com Imprimir este apartado Página anterior Subir un nivel Página siguiente

Inicio >  La interfaz de DatabaseSpy > Editores y ventanas de comparación >

Editor de diseños

El Editor de diseños es una interfaz de usuario gráfica que sirve para ver los objetos de la BD y sus relaciones en forma de objetos gráficos. Las tablas, sus columnas, índices, claves y restricciones se presentan en lo que se denomina diseño de tabla (véase Ver la estructura de la tabla). El usuario puede añadir tablas nuevas, editar tablas ya disponibles o arrastrar tablas desde el Explorador para ver su estructura.

Clic para ampliar

Editor de diseños

 

Cuando se añaden objetos nuevos (p. ej. tablas o columnas) a la BD o se cambia su estructura, estos cambios no surten efecto en la BD inmediatamente. Los cambios en el diseño de la BD se registran en un script de cambios de la estructura de la base de datos y se pueden ejecutar o rechazar.

 

 

Opciones de diseño

Cuando se hace clic con el botón derecho en una zona en blanco del Editor de diseños, aparece un menú contextual con varios comandos (ver más abajo). Algunos de estos comandos también están disponibles en la barra de herramientas y tienen accesos directos.

 

New Table (Ctrl+T)

Crear tabla nueva

Ctrl+T

Crea una tabla nueva en la ventana activa del Editor de diseños y la asigna automáticamente al origen de datos activo (es decir, el origen de datos que está seleccionado en el Explorador).

Sticky Note (Alt+N)

Agregar nota adhesiva

Alt+N

Añade una nota adhesiva en la ventana del Editor de diseños.


Seleccionar | Seleccionar tablas de usuario

Alt+T

Selecciona todas las tablas de usuario que hay en la ventana activa del Editor de diseños.


Seleccionar | Seleccionar tablas de sistema

Alt+S

Selecciona todas las tablas de sistema que hay en la ventana activa del Editor de diseños.

Hierachical Layout

Aplicar diseño automático a todo el diagrama


Ordena los componentes del diseño de forma jerárquica teniendo en cuenta todas las relaciones que existen entre las tablas.

Save Diagram as Image

Guardar el diagrama como imagen


Guarda el diseño activo en formato de gráficos de red portátiles (*.png) o como metarchivo de Windows mejorado (*.emf).

 

 

La barra de herramienta también ofrece estos comandos y funciones:

 

Change zoom factor



Cambia el factor del zoom de la ventana del Editor de diseños. Escriba el valor deseado o seleccione uno de la lista desplegable.

Zoom in (Ctrl+Num +)

Acercarse

Ctrl+Núm +

Aumenta el factor de zoom de la ventana del Editor de diseños un 10%. También puede aumentar el factor de zoom moviendo la rueda de desplazamiento del ratón hacia adelante mientras pulsa la tecla Ctrl.

Zoom out (Ctrl+Num -)

Alejarse

Ctrl+Núm -

Disminuye el factor de zoom de la ventana del Editor de diseños un 10%. También puede reducir el factor de zoom moviendo la rueda de desplazamiento del ratón hacia atrás mientras pulsa la tecla Ctrl.

Zoom Fit

Ajustar al tamaño


Ajusta el tamaño del área de trabajo hasta que todas las tablas se puedan ver en la ventana activa del Editor de diseños.

Insert Referenced Tables

Insertar tablas a las que se hace referencia


Inserta todas las tablas relacionadas a las que hace referencia una restricción de la tabla seleccionada.

Insert Referencing Tables

Insertar tablas que hacen referencia


Inserta todas las tablas relacionadas que tengan una restricción que haga referencia a la tabla seleccionada.

Insert All Related Tables

Insertar todas las tablas relacionadas


Inserta todas las tablas relacionadas, tanto las que hacen referencia como las tablas a las que se hace referencia.

Expand selected Tables

Expandir las tablas seleccionadas


Expande todas las tablas que están seleccionadas en la ventana activa del Editor de diseños.

Collapse selected Tables

Contraer las tablas seleccionadas


Contrae todas las tablas que están seleccionadas en la ventana activa del Editor de diseños.

Snap to Grid (Ctrl+G)

Ajustar a la cuadrícula

Ctrl+G

Muestra/oculta la cuadrícula y activa/desactiva la función de ajuste a la cuadrícula.

Export

Exportar


Abre el cuadro de diálogo Exportar datos de la base de datos (el botón de opción Tabla está preseleccionado en el cuadro de diálogo).

Update Change Script

Actualizar el script de cambios


Genera un script de cambios o lo actualiza si se realizaron cambios en la estructura de la BD. Este icono se deshabilita si eligió el botón de opción Instantáneamente en el cuadro de diálogo "Opciones" (Herramientas | Opciones | General | Script de cambios).

Show Options

Mostrar opciones


Abre el cuadro de diálogo "Opciones", donde puede personalizar la configuración del Editor de diseños.

 

El menú contextual de los diseños de tabla contiene comandos diferentes dependiendo de dónde se haga clic con el botón derecho.


© 2019 Altova GmbH