Menüs und Symbolleisten

www.altova.com Dieses Kapitel drucken Vorherige Seite Eine Ebene nach oben Nächste Seite

Startseite >  XMLSpy Tutorial > XMLSpy-Benutzeroberfläche >

Menüs und Symbolleisten

In diesem Abschnitt des Tutorials werden die Hauptfunktionen der Menüs und Symbolleisten von XMLSpy erläutert.

 

Menüs

Es gibt zwei Hauptleisten: (i) ein Standardmenü, das angezeigt wird, wenn kein Dokument geöffnet ist und (ii) das vollständige XMLSpy Applikationsmenü, das angezeigt wird, sobald ein Dokument geöffnet ist. Gehen Sie folgendermaßen vor:

 

1.Schließen Sie alle offenen Dokumente mit dem Menübefehl Datei | Alles schließen. Daraufhin wird das Standardmenü angezeigt.
2.Öffnen Sie die Datei AddressFirst.xsd durch Klicken auf ihren Namen in der Liste der zuletzt geöffneten Dateien ganz unten im Menü Datei. Sobald die Datei in der Schema-Ansicht geöffnet ist, ändert sich das Menü und Sie sehen das vollständige XMLSpy-Applikationsmenü.

 

 

Die Menüs sind in erster Linie nach Funktion geordnet. Ein Befehl in einem Menü ist nur dann aktiv, wenn er an der Stelle, an der sich der Cursor gerade befindet, ausgeführt werden kann oder, um in der aktuellen Ansicht des aktiven Dokuments eine Auswahl vornehmen zu können. Um zu sehen, unter welchen Umständen ein Menübefehl aktiv oder inaktiv ist, führen Sie die folgenden Schritte durch:

 

1.Klicken Sie auf das Menü Schema-Design. Beachten Sie, dass die Befehle Diagramm speichern, Ansicht konfigurieren und Vergrößern/Verkleinern deaktiviert sind (Abbildung unten).

TutMenu01

2.Klicken Sie in einen leeren Bereich außerhalb des Menüs, damit das Menü nicht mehr angezeigt wird. Klicken Sie anschließend auf die Schaltfläche Diagramm anzeigen ic_component links von der Elementkomponente. Daraufhin wechseln Sie in die Content Model-Ansicht der Schema-Ansicht (dies ist die zweite der beiden Schema-Ansichten; die erste ist die Schema-Übersicht). Wenn Sie nun das Menü "Schema-Design" öffnen, sehen Sie, dass die Befehle Diagramm speichern, Ansicht konfigurieren und Vergrößern/Verkleinern nun aktiv sind. Diese Befehle sind nur in der Content Model-Ansicht der Schema-Ansicht, nicht aber in dedr Schema-Übersicht der Schema-Ansicht aktiv. Beachten Sie außerdem, dass nur XML-Schema-Dateien in der Schema-Ansicht geöffnet werden können.
3.Eine XML-Schema-Datei ist gleichzeitig eine XML-Datei, daher wird sie in der Text- und Grid-Ansicht als XML-Datei angezeigt. In diesen Ansichten sind alle Menübefehle, die sich auf XML-Dateien anwenden lassen, aktiv. Vergleichen Sie die Befehle im Menü Bearbeiten in der Schema- und Text-Ansicht miteinander (ob sie aktiv sind oder nicht).
4.Vergleichen Sie als Nächstes die Befehle im Menü XML | Einfügen in der Text- und  der Grid-Ansicht (ob sie aktiv sind oder nicht). Die Befehle in diesem Menü sind nur in der Grid-Ansicht aktiv.

 

Eine Beschreibung aller Menübefehle finden Sie im Abschnitt Menübefehle des Benutzerhandbuchs.

 

Symbolleisten

Die Anzeige der Symbolleisten variiert je nachdem, welche Ansicht aktiv ist. In der Standardeinstellung sind die richtigen Symbolleisten für die einzelnen Ansichten definiert. Daher unterscheiden sich die angezeigten Symbolleisten je nach Ansicht. Sie können die Symbolleisten allerdings im Dialogfeld "Anpassen" auf dem Register "Symbolleisten" (Extras | Anpassen | Symbolleisten, Abbildung unten) auch anpassen.

new_mnu_customize_toolb

Üben Sie nun das Verschieben der Symbolleisten auf der Benutzeroberfläche. Klicken Sie auf den Ziehpunkt einer Symbolleiste und ziehen Sie die Symbolleiste an die gewünschte Stelle auf der Benutzeroberfläche. (Der Ziehpunkt wird durch die vertikale gepunktete Linie auf der linken Seite jeder Symbolleiste gekennzeichnet; siehe Abbildung unten).

TutToolbar01

Versuchen Sie, eine Symbolleist an die folgenden Stellen zu ziehen: (i) in eine andere Zeile im Symbolleistenbereich; (ii) nach links oder rechts von einer anderen Symbolleiste; (iii) in die Mitte des Hauptfensters; (iv) angedockt an die linke oder rechte Seite des Applikationsfensters (dazu muss der Ziehpunkt über den linken bzw. rechten Rand des Fensters platziert werden).

 

Schließen Sie anschließend die Datei AddressFirst.xsd wieder.

 


© 2019 Altova GmbH