Aktivieren Sie bitte JavaScript, um diese Seite anzeigen zu können.

Altova XMLSpy 2020 Professional Edition

In XMLSpy stehen verschiedene Einstellungen und Optionen zur Auswahl. In diesem Abschnitt erhalten Sie einen kurzen Überblick über diese Optionen. Außerdem werden einige Aspekte der XMLSpy Menüs kurz erläutert. Dieser Abschnitt ist in die folgenden Teile gegliedert.

 

Einstellungen

Anpassung

Menüs

 

Einstellungen

Auf den verschiedenen Registern im Dialogfeld "Optionen" wird eine Reihe wichtiger XMLSpy-Einstellungen definiert (Abbildung unten, Aufruf des Dialogfelds mit dem Befehl Extras | Optionen). Gehen Sie die verschiedenen Optionen selbst durch, um zu sehen, welche Optionen zur Verfügung stehen.

 

tools_sett_file

 

Im Folgenden finden Sie eine Zusammenfassung der wichtigsten Einstellungen. Nähere Informationen dazu finden Sie im Abschnitt "Benutzerreferenz" in der Beschreibung des Dialogfelds "Optionen".

 

Dateiarten und Standardansichten: Auf dem Register "Dateiarten" können Sie eine Dateiart hinzufügen, damit XMLSpy sie erkennt. Fügen Sie dazu eine Dateierweiterung zur Liste der Dateierweiterungen hinzu. Anschließend können Sie für jede Dateiart festlegen, welcher Spezifikation Dateien dieses Typs entsprechen sollen und in welcher XMLSpy-Ansicht Dateien dieses Typs geöffnet werden sollen (die Standardansicht für diesen Dateityp).

Dateivalidierung: Auf dem Register "Datei" können Sie festlegen, ob Dateien beim Öffnen und/oder Speichern automatisch validiert werden sollen. Anschließend können Sie auf dem Register "Dateiarten" die Dateivalidierung für bestimmte Dateiarten deaktivieren.

Bearbeitungsfunktionen: Auf dem Register "Bearbeiten" können Sie festlegen, wie Eingabehilfen organisiert sein sollen, wie neue Elemente generiert werden und ob die Autokomplettierungsfunktion aktiviert werden soll. Für einzelne Ansichten stehen auf dem Register "Ansicht" zusätzliche Optionen zur Verfügung. Auf den Schriftartregistern für die einzelnen Ansichten können Sie die Schriftarteigenschaften für einzelne Node-Typen in den einzelnen Ansichten definieren.

XSLT- und FO-Prozessor: Auf dem Register "XSL" können Sie festlegen, dass ein externer XSL-Prozessor für Transformationen  verwendet werden soll, die über die Benutzeroberfläche gestartet werden. Dabei müssen Sie außerdem den Pfad zur ausführbaren Datei für den FO-Prozessor, der für die FO-Verarbeitung in XMLSpy verwendet werden soll, festlegen. Nähere Informationen dazu finden Sie im Abschnitt XSLT-Verarbeitung.

Kodierung: Auf dem Register "Kodierung" wird die Standardkodierung für XML- und nicht-XML-Dateien definiert.

 

Anpassung

Sie können verschiedene Aspekte von XMLSpy anpassen, wie unter anderem auch das Aussehen der Benutzeroberfläche. Die entsprechenden Optionen dazu finden Sie im Dialogfeld "Anpassen" (Abbildung unten)  

 

new_mnu_customize_commands

 

Die verschiedenen Konfigurationsoptionen sind im Abschnitt Benutzerreferenz beschrieben.

 

Menüs

Menübefehle sind abhängig von drei Faktoren aktiv/deaktiviert: (i) Dateiart, (ii) aktiver Ansicht und (iii) aktueller Cursorposition oder aktuellem Dokumentstatus. z.B:

 

Dateiarten: Der Befehl DTD/Schema | Weitere DTD einfügen ist nur dann aktiv, wenn es sich bei der aktiven Datei um eine DTD handelt; so sind auch Befehle im Menü WSDL nur aktiv, wenn eine WSDL-Datei aktiv ist.

Aktive Ansicht: Die meisten Befehle im Menü Schema-Design werden erst aktiv, wenn die aktive Ansicht die Schema-Ansicht ist.

Aktuelle Cursorposition, Dokumentstatus: Ob in der Grid-Ansicht der Befehl zum Hinzufügen eines Attributs als Child-Node  (XML | Child hinzufügen | Attribute) aktiv ist, hängt davon ab, ob es sich beim ausgewählten Node in der Grid-Ansicht um ein Element handelt oder nicht (aktuelle Cursorposition). Wenn ein XSLT-Dokument aktiv ist, steht der Befehl Debugger anhalten erst nach Beginn der Debugging-Sitzung zur Verfügung (aktueller Dokumentstatus).

 

Beachten Sie, dass Sie auch Menüs anpassen können (Extras | Anpassen) und sie durch Ziehen auch an eine andere Stelle der Benutzeroberfläche ziehen können (siehe Menüleiste, Symbolleisten, Statusleiste).

 

© 2019 Altova GmbH