Hauptfenster

www.altova.com Dieses Kapitel drucken Vorherige Seite Eine Ebene nach oben Nächste Seite

Startseite >  Benutzerhandbuch und Referenz > Benutzeroberfläche und Umgebung > Die grafische Benutzeroberfläche >

Hauptfenster

Das Hauptfenster (Abbildung unten) ist der Bereich, in dem alle Dokumente angezeigt und bearbeitet werden.

 

MainWindow

 

Dateien im Hauptfenster

 

Sie können eine beliebige Anzahl an Dokumenten gleichzeitig geöffnet haben und bearbeiten.
Jedes offene Dokument hat sein eigenes Fenster und ein Register mit seinem Namen am unteren Rand des Hauptfensters. Um ein Dokument zum aktiven zu machen, klicken Sie auf sein Register.
Wenn mehrere Dateien geöffnet sind, werden manchmal auf Grund von Platzmangel in der Dokumentregisterleiste nicht alle Register angezeigt. Um Dokumentregister zu sehen, (i) verwenden Sie entweder die Scroll-Schaltflächen  rechts unten in der Dokumentregisterleiste oder (ii) wählen Sie das gewünschte Dokument aus der Liste im unteren Bereich des Menüs Fenster aus.
Wenn das aktive Dokument maximiert ist, befinden sich die Schaltflächen zum Minimieren, Wiederherstellen und Schließen auf der rechten Seite der Menüleiste. Wenn ein Dokument überlappend, nebeneinander oder minimiert angezeigt wird, befinden sich die Schaltflächen zum Maximieren, Wiederherstellen und Schließen in der Titelleiste des Dokumentfensters.
Wenn Sie eine Datei maximieren, werden auch alle anderen offenen Dateien maximiert.
Um offene Dateien überlappend oder nebeneinander anzuzeigen, verwenden Sie die Befehle im Menü Fenster.
Sie können offene Dateien auch durch Verwendung von Strg+Tab oder Strg+F6 in der Reihenfolge aktivieren, in der sie geöffnet wurden.
Durch Rechtsklick auf ein Dokumentregister wird ein Kontextmenü mit einer Auswahl an Datei-Befehlen wie z.B. Drucken und Schließen angezeigt.

 

Ansichten im Hauptfenster

Das aktive Dokument kann auf verschiedene Arten angezeigt und bearbeitet werden. Die verfügbaren Ansichten werden in einer Leiste oberhalb der Dokumentregister angezeigt (siehe Abbildung oben), wobei die aktive Ansicht markiert erscheint. Um eine Ansicht auszuwählen, klicken Sie auf die entsprechende Ansichtsschaltfläche oder rufen Sie im Menü Ansicht den entsprechenden Befehl auf.

 

Verfügbar sind entweder Editier- oder Browser-Ansichten:

 

Textansicht: Eine Editieransicht mit Syntaxfärbung für die Arbeit am Dokumentcode selbst.
Grid-Ansicht: Zur strukturierten Bearbeitung. Das Dokument wird in Tabellenform dargestellt und kann grafisch bearbeitet werden. Diese Ansicht enthält auch eine eingebettete Tabellen-Ansicht, in der sich wiederholende Elemente in Tabellenform dargestellt werden.
Schema-Ansicht: Zum Anzeigen und Bearbeiten von XML-Schemas.
WSDL-Ansicht: Zum Anzeigen und Bearbeiten von WSDL-Dokumenten.
Authentic-Ansicht: Zum Bearbeiten von XML-Dokumenten in einer grafischen Ansicht auf Basis von StyleVision Power Stylesheets
Browser-Ansicht: Eine integrierte Browser-Ansicht, die sowohl CSS- als auch XSL-Stylesheets unterstützt.

 

Hinweis: Sie können die Standardansicht für bestimmte Dateierweiterungen im Dialogfeld Extras | Optionen anpassen: Gehen Sie dazu auf dem Register "Dateiarten" zum Fenster "Standardansicht".

 


© 2019 Altova GmbH