Optionen

www.altova.com Dieses Kapitel drucken Vorherige Seite Eine Ebene nach oben Nächste Seite

Startseite >  Menüreferenz > Extras >

Optionen

Wählen Sie den Menüeintrag Extras | Optionen, um Ihre Projektoptionen zu definieren.

 

Auf dem Register Ansicht können Sie folgende Einstellungen festlegen:

 

wo das Programmlogo angezeigt werden soll.
den Inhalt der Applikationstitelleiste
die Elementarten, die aufgelistet werden sollen, wenn Sie auf dem Register "Model-Struktur" oder "Favoriten" auf die Kontextmenüoption "In keinem Diagramm verwendete Elemente auflisten" klicken. Sie haben auch die Möglichkeit, Elemente in inkludierten Dateien zu ignorieren.
ob ein in einem Diagramm ausgewähltes Element in der Modell-Struktur automatisch ausgewählt/synchronisiert werden soll.
die Standardtiefe der hierarchischen Ansicht auf dem Register "Hierarchie" bei Verwendung der Option Graph. Ansicht anzeigen .
Die Einstellungen für automatisches hierarchisches Layout, über Sie für das Hierarchiefenster die Verschachtelungstiefe nach oben und unten festlegen können.
"Jedes Element nur einmal erweitern". Dadurch kann im selben Bild/Diagramm kann nur eines derselben Classifier-Elemente erweitert werden.
ob Sie Elemente beim Ziehen mit der Maus in einem Diagramm an Hilfslinien ausrichten möchten.

 

       um_dlg_options_view

 

Auf dem Register Bearbeiten können Sie folgende Einstellungen definieren:

 

Ob ein neues auf dem Register "Modell-Struktur" erstelltes Diagramm im Hauptfenster automatisch geöffnet werden soll.
Standardsichtbarkeit beim Hinzufügen neuer Elemente - Eigenschaften oder Operationen.
die Standard-Codesprache, wenn eine neue Komponente hinzugefügt wird.
Ob eine neu hinzugefügte Einschränkung auch ihren Besitzer (Owner) einschränken soll.
Ob Sie gefragt werden möchten, bevor Elemente aus einem Projekt, vom Register Favoriten oder aus einem der Diagramme gelöscht werden. Wenn Sie Elemente hier löschen, kann diese Eingabeaufforderung deaktiviert werden. Sie können die Eingabeaufforderung "vor dem Löschen fragen" hier zurücksetzen.
Die Zeit nach der Syntaxfehler-Popup-Fenster geschlossen werden sollen.

 

um_dlg_options_editing

 

 

Auf dem Register Diagrammbearbeitung können Sie folgende Einstellungen definieren:

 

wie viele Objekte automatisch zu einem Diagramm hinzugefügt werden können, bevor eine Eingabeaufforderung erscheint.
die Anzeige von Stilen, wenn diese automatisch zu einem Diagramm hinzugefügt werden.
ob automatisch Assoziationen zwischen Modellelementen erstellt werden sollen, wenn Elemente zu einem Diagramm hinzugefügt werden.
ob die Assoziationen zu Collections aufgelöst werden sollen.
ob Vorlagen von unbekannten externen Elementen als nicht vollständig qualifiziert aufgelöst werden sollen.
ob bestehende Collection-Vorlagen verwendet oder neue definiert werden sollen.

 

Collection-Vorlagen sollten als voll qualifiziert definiert werden, also a.b.c.List. Wenn die Vorlage diesen Namespace hat, erstellt UModel automatisch eine Collection-Assoziation. Ausnahme: Wenn die Vorlage zum Paket der unbekannten externen Elemente gehört und die Option "Unbekannte externe Elemente: nicht qualifizierte auflösen" aktiviert ist, so wird nur der Vorlagenname berücksichtigt (d.h. List anstelle von a.b.c.List).

 

Ob das Autokomplettierungsfenster bei der Bearbeitung von Attributen oder Operationen im Klassendiagramm verfügbar sein soll.

 

um_dlg_options_diagram

Auf dem Register Datei können Sie folgende Einstellungen definieren:

 

welche Aktionen durchgeführt werden sollen, wenn Dateien geändert werden.
ob der Inhalt des Registers "Favoriten" sowie alle derzeit offenen Diagramme mit dem aktuellen Projekt geladen und gespeichert werden soll.
ob das zuletzt geöffnete Projekt beim Starten der Applikation automatisch geöffnet werden soll.
ob die Projektdatei mit CR/LF-Zeilen und Tabulatoreinrückungen im Pretty-Print-Format gespeichert werden soll.

 

um_dlg_options_file

 

Auf dem Register Code Engineering können Sie folgende Einstellungen vornehmen:

 

die Umstände, unter denen das Meldungsfenster angezeigt werden soll.
ob alle Code-Elemente, d.h. jene, die in einer Java-, C# - oder VB-Namespace Root enthalten sind, sowie jene, die einer Java-, C#- oder VB-Komponente zugewiesen sind, überprüft werden sollen oder ob nur Elemente, die für das Code Engineering verwendet werden, d.h. Elemente, bei denen das Kontrollkästchen "für Code Engineering verwenden" aktiv ist, überprüft werden sollen.
ob im zusammenzuführenden Code fehlende Codedateinamen generiert werden sollen.
Beim Aktualisieren von Programmcode:
ob eine Syntaxüberprüfung durchgeführt werden soll.
ob fehlende Komponentenrealisierungen automatisch generiert werden sollen.
ob im zusammengeführten Code fehlende Codedateinamen generiert werden sollen
ob im Codedateipfad Namespaces verwendet werden sollen
Die im Code verwendete Einrückungsmethode, d.h. Tabulatoren oder beliebig viele Leerzeichen
welche Verzeichnisse beim Aktualisieren eines UModel-Projekts anhand von Code oder einem Verzeichnis ignoriert werden sollen. Trennen Sie die einzelnen Verzeichnisse durch ein Semikolon ";". Untergeordnete Verzeichnisse desselben Namens werden ebenfalls ignoriert.
den Pfad zur XMLSpy-Datei RootCatalog.xml, welche es UModel sowie XMLSpy erlaubt, allgemein verwendete Schemas (sowie Stylesheets und andere Dateien) aus lokalen Benutzerordnern aufzurufen. Dadurch wird die allgemeine Verarbeitungsgeschwindigkeit erhöht und Benutzer können auf diese Art auch offline arbeiten.

 

um_dlg_options_code

 

Auf dem Register Versionskontrolle können Sie folgende Einstellungen vornehmen:

 

Auswahl des aktuellen Versionskontroll-Plug-in über die Auswahlliste. Über die Schaltfläche "Erweitert" können Sie die genauen Einstellungen für das ausgewählte Versionskontroll-Plug-in definieren. Diese Einstellungen sind unterschiedlich, je nachdem, welches Versionskontroll-Plug-in Sie verwenden.
Die Anmelde-ID für das Versionskontrollsystem.
Spezifische Ein- und Auscheck-Einstellungen.
Die Schaltfläche "Zurücksetzen" steht zur Verfügung, wenn Sie in einem der Dialogfelder die Option "Wenn Dialogfelder mit "..nicht mehr anzeigen" ausgeblendet waren, klicken Sie auf "Zurücksetzen", damit sie wieder angezeigt werden" aktiviert haben. Daraufhin wird diese "nicht mehr anzeigen"-Meldung wieder angezeigt.

 

um_dlg_options_source

 

 

Auf dem Register Skripting-Umgebung können Sie folgende Einstellungen vornehmen:

 

ob die Skripting-Umgebung für das aktuelle UModel-Projekt aktiv sein soll.
welche globale Skripting-Datei Sie verwenden möchten
wenn beim Start von UModel automatische Makros ausgeführt werden sollen
ob Skripting-Ereignisse verarbeitet werden sollen.

 

um_dlg_options_scripting

 

 

Informationen zu den Einstellungen auf dem Register Netzwerk-Proxy finden Sie unter Netzwerk-Proxy-Einstellungen.


© 2019 Altova GmbH