Erstellen, Öffnen und Speichern von Projekten

www.altova.com Dieses Kapitel drucken Vorherige Seite Eine Ebene nach oben Nächste Seite

Startseite >  Projekte und Code Engineering > Verwalten von UModel-Projekten >

Erstellen, Öffnen und Speichern von Projekten

Wenn Sie UModel zum ersten Mal starten, wird automatisch ein neues Projekt geöffnet. Bei späteren Ausführungen wird das zuletzt verwendete Projekt geöffnet.

 

Anmerkung:UModel enthält eine Reihe von Beispielprojekten, anhand welcher Sie die Grundlagen der Modellierung erlernen und die grafische Benutzeroberfläche von UModel kennenlernen können. Diese Projekte befinden sich im folgenden Ordner: C:\\Benutzer\<Benutzername>\Dokumente\Altova\UModel2019\UModelExamples.

 

So erstellen Sie ein neues Projekt:

Klicken Sie im Menü Datei auf Neu (oder klicken Sie auf die Symbolleistenschaltfläche Neu).

 

Daraufhin wird ein neues Projekt mit dem Standardnamen NeuesProjekt1 erstellt. Außerdem werden die folgenden Pakete automatisch zum Projekt hinzugefügt und im Fenster "Modell-Struktur" angezeigt.

 

Root
Component View

 

Diese beiden Pakete haben einen speziellen Zweck und sind die einzigen, die, wie im Tutorial unter Forward Engineering (Modell zu Code) erläutert, nicht umbenannt oder gelöscht werden können.

 

Nachdem Sie das Projekt erstellt haben, können Sie Modellierungselemente wie UML-Pakete und Diagramme dazu hinzufügen, siehe Erstellen von Elementen und Erstellen von Diagrammen.

 

So fügen Sie ein neues Paket hinzu:

1.Rechtsklicken Sie auf das Paket, unter dem das neue Paket angezeigt werden soll (in einem neuen Projekt entweder "Root" oder "Component View").
2.Wählen Sie im Kontextmenü den Befehl Neues Element | Paket.

 

Beachten Sie, dass Paket sowie andere Modellierungselemente auch über UML-Diagramme hinzugefügt werden können. Sie werden in diesem Fall automatisch im Fenster "Modell-Struktur" angezeigt.

 

 

So fügen Sie ein neues Diagramm hinzu:

Klicken Sie mit der rechten Maustaste auf ein Paket in der Modell-Struktur und wählen Sie Neues Diagramm.

 

 

So fügen Sie Elemente zu einem Diagramm hinzu:

oWählen Sie eine der folgenden Methoden:
Klicken Sie mit der rechten Maustaste auf das Diagramm und Wählen Sie Neu | <Elementart> aus dem Kontextmenü aus.
Ziehen Sie das gewünschte Element aus der Symbolleiste.

 

Ein Arbeitsbeispiel zur Erstellung eines Projekts und zum Generieren von Programmcode anhand dieses Projekts finden Sie unter Forward Engineering (Modell zu Code).

 

 

So öffnen Sie ein vorhandenes Projekt:

Klicken Sie im Menü Datei auf Öffnen und navigieren Sie zur .ump-Projektdatei.

 

Anmerkung:Externe Änderungen, die an der Projektdatei oder inkludierten Dateien extern vorgenommen wurden, werden automatisch erkannt und es erscheint eine entsprechende Meldung, ob das Projekt neu geladen werden soll. Diese Funktion kann über Extras | Optionen | Register Datei deaktiviert werden.

 

 

So speichern Sie ein Projekt:

Klicken Sie im Menü Datei auf Speichern (oder Speichern unter).

 

Alle projektrelevanten Daten werden in der UModel-Projektdatei (Dateierweiterung *.ump (UModel-Projektdatei) gespeichert.

 

Anmerkung:Die *.ump-Datei ist ein XML-Dateiformat, auf das beim Speichern die Option "Pretty Print" aus dem Menü Extras | Optionen | Register Datei angewendet werden kann.

© 2019 Altova GmbH