Ausrichten von Modellierungselementen und Anpassen der Größe

www.altova.com Dieses Kapitel drucken Vorherige Seite Eine Ebene nach oben Nächste Seite

Startseite >  Anleitung zur Modellierung von... > Diagramme >

Ausrichten von Modellierungselementen und Anpassen der Größe

Sie können die Größe von Elementen im Diagramm folgendermaßen anpassen:

 

1.Klicken Sie auf ein Element im Diagramm. Daraufhin werden rund um das Diagramm herum mehrere schwarze Punkte angezeigt..

um_element_waypoints

2.Ziehen Sie einen der schwarzen Punkte in die Richtung, in die das Diagramm vergrößert werden soll.

 

Um die Elementgröße wieder auf die Originalgröße zurückzusetzen, wählen Sie eine der folgenden Methoden:

 

Klicken Sie an der rechten unteren Ecke des Elements auf das Symbol Automatische Größenanpassung aktivieren.

um_element_autosize

Klicken Sie mit der rechten Maustaste auf ein Element im Diagramm und wählen Sie im Kontextmenü den Befehl Größe automatisch anpassen..
Wählen Sie ein oder mehrere Elemente aus. Klicken Sie im Menü Layout auf Größe automatisch anpassen.

 

Wenn in Diagramm mindestens zwei Modellierungselemente ausgewählt wurden, können diese aneinander ausgerichtet werden (so können z.B. beide waagrecht oder senkrecht aneinander ausgerichtet werden, oder in der Größe angeglichen werden). Die Befehle zum Ausrichten oder Anpassen der Größe von Elementen finden Sie im Menü Layout sowie in der gleichnamigen Symbolleiste.

um_layout_toolbar

Layout-Symbolleiste

Wenn Sie mehrere Elemente markieren, wird für die Aktion, die Sie daran ausführen (Ausrichten oder Größe anpassen), als Vorlage das zuletzt ausgewählte Element verwendet. Wenn Sie z.B. drei Klassenelemente auswählen und den Befehl Breite angleichen aufrufen, dann werden alle drei Elemente in der Breite an die zuletzt ausgewählte Klasse angepasst. Das zuletzt ausgewählte Element wird immer mit einer strichlierten Umrandung angezeigt.

 

 

In der folgenden Tabelle finden Sie die Befehle für die Ausrichtung von Elementen und die Anpassung ihrer Größe:

 

Symbol

Befehl

Anmerkungen

um_ic_align_left

Linksbündig


um_ic_align_right

Rechtsbündig


um_ic_align_top

Bündig oben


um_ic_align_bottom

Bündig unten


um_ic_center_vertically

Vertikal zentrieren


um_ic_center_horizontally

Horizontal zentrieren


um_ic_space_across

Waagrecht verteilen

Dieser Befehl steht zur Verfügung, wenn drei oder mehr Elemente ausgewählt sind. Die waagrechten Abstände zwischen den ausgewählten Elementen werden dadurch gleich groß gemacht.

um_ic_space_down

Senkrecht verteilen

Dieser Befehl steht zur Verfügung, wenn drei oder mehr Elemente ausgewählt sind. Die senkrechten Abstände zwischen den ausgewählten Elementen werden dadurch gleich groß gemacht.

um_ic_line_up_horizontally

Horizontal anordnen

Mit diesem Befehl werden alle ausgewählten Elemente im Diagramm neu positioniert, so dass sie waagrecht nebeneinander angeordnet werden.

um_ic_line_up_vertically

Vertikal anordnen

Mit diesem Befehl werden alle ausgewählten Elemente im Diagramm neu positioniert, so dass sie senkrecht übereinander angeordnet werden.

um_ic_make_same_width

Breite angleichen


um_ic_make_same_height

Höhe angleichen


um_ic_make_same_size

Größe angleichen


 

Sie können auch ein automatisches Layout für alle Elemente im Diagramm durchführen. Gehen Sie dazu folgendermaßen vor:

 

Klicken Sie im Menü Layout auf Automatisches Layout und wählen Sie eine der folgenden Optionen aus: Zentriert, Hierarchisch oder Block.

 

Zentriert

Zeigt die Modellierungselemente in der Mitte zentriert an.

Hierarchisch

Zeigt die Elemente nach ihren hierarchischen Beziehungen an. So wird z.B. eine übergeordnete Klasse oberhalb der davon abgeleiteten Klassen angezeigt.

 

Die Optionen für hierarchisches Layout können über das Menü Extras | Optionen, Register Ansicht, Gruppe Hierarchisch anordnen angepasst werden.

Block

Zeigt die Elemente rechteckig nach Elementgröße gruppiert an.


© 2019 Altova GmbH