Aufrufen häufig verwendeter Menüs und Funktionen

www.altova.com Dieses Kapitel drucken Vorherige Seite Eine Ebene nach oben Nächste Seite

Startseite >  MapForce Plug-in für Eclipse >

Aufrufen häufig verwendeter Menüs und Funktionen

Sie können in Eclipse die meisten MapForce-Funktionen über dasselbe Menü wie in der Standalone-Version aufrufen. Es gibt allerdings einige Eclipse-spezifische Abweichungen, die unten aufgeführt sind. Dies ist die Standardkonfiguration; Sie können die Einstellungen der Benutzeroberfläche allerdings auf Wunsch über Eclipse weiter anpassen (siehe Die MapForce-Perspektive).

 

Anmerkung:Einige MapForce-Menügruppen oder - befehle sind in Eclipse deaktiviert (oder nicht verfügbar), wenn der Kontext nicht relevant ist. So steht z.B. das Menü Einfügen nur zur Verfügung, wenn eine Mapping-Design-Datei (.mfd) in Eclipse aktiv ist.

 

Informationen zu den MapForce-Standardmenüs finden Sie in der Menüreferenz.

 

Allgemeine MapForce-Befehle

In der Standalone-Edition von MapForce stehen die Befehle zu Mapping-Design-Dateien (wie z.B. Validieren, Auf FlowForce Server bereitstellen, Code generieren, usw.) im Menü Datei zur Verfügung. In Eclipse stehen diese Befehle im Menü MapForce bzw. in der MapForce-Symbolleiste zur Verfügung. Beachten Sie, dass die Befehle zum Öffnen oder Speichern von Dateien (einschließlich MapForce-Projektdateien) im Menü Datei von Eclipse zur Verfügung stehen.

gui_mf_eclipse_toolbar

Die MapForce-Symbolleiste in Eclipse

Die Symbolleisten-Schaltfläche gui_mf_eclipse_help öffnet die MapForce-Hilfedatei.

 

Über die Symbolleisten-Schaltfläche toolbar_mapforce werden MapForce-dateispezifische Befehle angezeigt. Wenn Sie diese Schaltfläche erweitern, hängt es von der im Eclipse-Editor derzeit aktiven Datei ab, welche Befehle zur Verfügung stehen. So stehen z.B. die Befehle für Mapping-Dateien (.mfd) zur Verfügung, wenn eine solche Datei im Eclipse-Editor aktiv (im Fokus) ist.

 

Debuggen von Mappings

Die Befehle zum Debuggen von Mappings befinden sich im Menü MapForce | Debuggen und in der Debugging-Symbolleiste. Beachten Sie, dass die Debugging-Tastenkürzel (wie F5, F10, usw) in Eclipse bereits vorreserviert sind und nicht zur Verfügung stehen.

 

 

Globale Ressourcen

Um globale Ressourcen aufrufen oder verwalten zu können, wählen Sie eine der folgenden Methoden:

 

Klicken Sie auf die MapForce-Symbolleisten-Schaltfläche, um sie zu erweitern und klicken Sie auf Globale Ressourcen.
Wählen Sie im Menü MapForce den Befehl Globale Ressourcen.

 

MapForce-Projekte

In der Standard Edition von MapForce enthält das Menü Projekt eine Reihe von Befehlen zu Mapping-Projektdateien (.mfp). In Eclipse können Sie diese Befehle folgendermaßen aufrufen:

 

Die Befehle zum Öffnen oder Speichern eines Projekts finden Sie im Eclipse-Menü Datei.
Andere projektspezifische Befehle stehen in Form von Kontextmenübefehlen zur Verfügung. Um die Kontextbefehle aufzurufen, erstellen oder öffnen Sie ein MapForce-Projekt (.mfp) in Eclipse und klicken Sie mit der rechten Maustaste auf das Projekt.

gui_mfp_eclipse

Beachten Sie, dass Sie in Eclipse neben MapForce-Standardprojekten (.mfp) auch Projekte vom Typ "MapForce/Eclipse" erstellen können. Solche Projekte haben eine zweifache Natur und können für die automatische Erstellung und Generierung von MapForce-Code konfiguriert werden. Siehe Arbeiten mit Mappings und Projekten.

 

MapForce-Optionen

Die MapForce-Optionen stehen über das Menü Fenster | Benutzervorgaben zur Verfügung. Wählen Sie in diesem Menü den Befehl MapForce und klicken Sie anschließend auf Dialog für die MapForce-Einstellungen öffnen.

mf_eclipse_options_zoom25

Dialogfeld "Einstellungen"

 

Fenster "Bibliotheken"

Das MapForce Fenster "Bibliotheken" steht in Eclipse Form einer Ansicht zur Verfügung. Standardmäßig befindet sich diese Ansicht links vom Editor-Hauptfenster (Alle MapForce-Ansichten werden in der Eclipse-Perspektive angezeigt, wenn die MapForce-Perspektive eingeschaltet ist, siehe auch Die MapForce-Perspektive).

 

MapForce Plug-in-Version

Um die aktuell installierte Version des MapForce Plug-in für Eclipse zu sehen, wählen Sie die Eclipse-Menüoption Hilfe | Info über Eclipse und klicken Sie auf die MapForce-Schaltfläche.

 

Hilfe und Support

Die MapForce Menüs "Hilfe", "Support Center", "Auf Updates überprüfen" und "Über" finden Sie im Eclipse-Menü Hilfe | MapForce-Hilfe.


© 2019 Altova GmbH