Aktivieren Sie bitte JavaScript, um diese Seite anzeigen zu können.

Altova MapForce 2021 Basic Edition

Die grafische Benutzeroberfläche von MapForce ist als integrierte Entwicklungsumgebung konzipiert. In der Abbildung unten sehen Sie die wichtigsten Komponenten der Benutzeroberfläche. Mit Hilfe des Menübefehls Extras | Anpassen können Sie die Einstellungen der Benutzeroberfläche ändern.

 

Mit Hilfe der Schaltflächen gui_window_buttons in der rechten oberen Ecke jedes Fensters können Sie das Fenster ein- und ausblenden sowie ab- und andocken. Um die Symbolleisten und Fenster wieder in Ihren ursprünglichen Zustand zurückzusetzen, verwenden Sie den Menübefehl Extras | Symbolleisten und Fenster wiederherstellen.

 

In der nachstehenden Abbildung sind die wichtigsten Bereiche der grafischen Benutzeroberfläche der (MapForce Basic Edition) dargestellt.

mf-gui-basic

 

Menüleiste und Symbolleisten

In der Menüleiste werden die Menübefehle angezeigt. Jede Symbolleiste enthält eine Reihe von Schaltflächen für verschiedene MapForce-Befehle. Sie können die Symbolleiste an ihren Ziehpunkten mit der Maus an eine andere Stelle ziehen.

 

Fenster "Bibliotheken"

Im Fenster "Bibliotheken" wird eine Liste der vordefinierten MapForce-Funktionen, geordnet nach Bibliotheken, angezeigt. Je nachdem, welche Transformationssprache Sie entweder über das Menü Ausgabe oder über die Sprachauswahl-Symbolleiste auswählen, stehen unterschiedliche Funktionen zur Verfügung, siehe auch Auswählen einer Transformationssprache. Wenn Sie benutzerdefinierte Funktionen erstellt oder externe Bibliotheken importiert haben, so werden auch diese im Fenster "Bibliotheken" angezeigt.

mf_libraries_window

Um eine Funktion nach Name oder Beschreibung zu suchen, geben Sie den Suchwert in das Textfeld am unteren Rand des Fensters Bibliotheken ein. Um alle Instanzen einer Funktion (im gerade aktiven Mapping) zu suchen, klicken Sie mit der rechten Maustaste auf die Funktion und wählen Sie im Kontextmenü den Befehl Alle Aufrufe suchen aus. Sie können den Datentyp der Funktion und ihre Beschreibung auch direkt im Fenster Bibliotheken anzeigen. Nähere Informationen dazu finden Sie unter Funktionen.

 

Fenster "Bibliotheken verwalten"

Über dieses Fenster können Sie alle benutzerdefinierten Funktionen (UDFs = user-defined functions) und importierten benutzerdefinierten Bibliotheken, die in derzeit geöffneten Mappings verwendet werden, anzeigen und verwalten.

 

Standardmäßig wird da Fenster "Bibliotheken verwalten" nicht angezeigt. Um es anzuzeigen, wählen Sie eine der folgenden Methoden:

 

Klicken Sie im Menü Ansicht auf Bibliotheken verwalten.

Klicken Sie im unteren Bereich des Fensters "Bibliotheken" auf die Schaltfläche Bibliotheken hinzufügen/entfernen.

mf_bas_manage_libraries_window

Sie können auswählen, ob benutzerdefinierte Funktionen (UDFs) und Bibliotheken nur für das gerade aktive (im Fokus befindliche) Mapping-Dokument (.mfd-Datei) oder für alle geöffneten Mapping-Dokumente angezeigt werden sollen. Um die importierten Funktionen und Bibliotheken für alle gerade offenen Mapping-Dokumente anzuzeigen, klicken Sie mit der rechten Maustaste in das Fenster und wählen Sie im Kontextmenü den Befehl Offene Dokumente anzeigen.

 

Um anstelle des Namens den Pfad des geöffneten Mapping-Dokuments anzuzeigen, klicken Sie mit der rechten Maustaste in das Fenster und wählen Sie im Kontextmenü den Befehl Dateipfade anzeigen.

 

Nähere Informationen dazu finden Sie unter Verwalten von Funktionsbibliotheken..

 

Fenster "Mapping"

Das Mapping-Fenster ist der Arbeitsbereich, in dem Sie Mappings erstellen. Über das Menü Einfügen können Sie Mapping-Komponenten (wie z.B. Dateien, Schemas, Konstanten, Variablen usw.) zum Mapping-Bereich hinzufügen (siehe Hinzufügen von Komponenten zum Mapping. Sie können auch Funktionen aus dem Fenster "Bibliotheken" in den Mapping-Bereich ziehen, siehe Hinzufügen von Funktionen zum Mapping.

 

XSLT-Bereich

Im XSLT-Fenster wird der anhand Ihres Mappings generierte XSLT-Transformationscode angezeigt. Um zu diesem Fenster zu wechseln, wählen Sie als Transformationssprache XSLT, XSLT2 oder XSLT3 aus und klicken Sie auf das Register mit dem entsprechenden Namen.

 

Dieses Fenster bietet Funktionalitäten zur Anzeige von Zeilennummern und zum Ein- und Ausklappen von Codeabschnitten. Um Codeabschnitte ein- oder auszuklappen, klicken Sie auf das "+" bzw."-"-Symbol am linken Fensterrand. Eingeklappte Codeabschnitte werden mittels Auslassungspunkten markiert. Um eine Vorschau des eingeklappten Abschnitts zu sehen, ohne diesen Abschnitt ausklappen zu müssen, platzieren Sie die Mauszeiger über die Auslassungspunkte. Daraufhin wird ein Tooltipp mit der Codevorschau angezeigt,  wie in der Abbildung unten gezeigt. Wenn der Abschnitt zu groß für die Vorschau ist, wird am Ende des Tooltipps ein weiteres Auslassungssymbol angezeigt.

mf_bas_xslt_pane

Um die Anzeigeeinstellungen (einschließlich Einrückung, Zeilenendemarkierungen und anderen) zu konfigurieren, klicken Sie mit der rechten Maustaste in das Fenster und wählen Sie im Kontextmenü den Befehl Einstellungen für Textansicht aus. Alternativ dazu können Sie auch auf die Symbolleisten-Schaltfläche Einstellungen für Textansicht ic_text_view_settings klicken.

 

Fenster "Ausgabe"

Im Ausgabefenster wird das Ergebnis der Mapping-Transformation (z.B. eine XML-Datei) angezeigt, wenn Sie auf die Schaltfläche Ausgabe klicken. Wenn beim Mapping mehrere Dateien generiert werden, können Sie der Reihe nach durch die einzelnen generierten Dateien navigieren.

mf_bas_output_pane

Dieses Fenster enthält auch Zeilennummerierung und eine Klappleiste, die ähnlich wie im Fenster "XSLT" (siehe oben) funktioniert.

 

Fenster "Übersicht"

Im Fenster "Übersicht" sehen Sie eine Gesamtübersicht über das Mapping-Fenster. Wenn das Mapping sehr groß ist, können Sie hier schnell zu einer bestimmten Stelle im Mapping-Bereich navigieren. Klicken Sie dazu auf das rote Rechteck und ziehen Sie es an die gewünschte Stelle.

mf_overview_window

 

Fenster "Meldungen"

Im Fenster "Meldungen" werden bei der Mapping-Vorschau oder bei Durchführung einer Mapping-Validierung Meldungen, Fehler und Warnungen angezeigt.

mf_messages_window

Um die Komponente oder Struktur, die die Informations-, Warn- oder Fehlermeldung verursacht hat, im Mapping-Bereich zu markieren, klicken Sie im Fenster "Meldungen" auf den unterstrichenen Text.

 

Die Ergebnisse der Mapping-Ausführung oder -Validierung werden im Fenster "Meldungen" mit einem der folgenden Statussymbole angezeigt:

 

Symbol

Beschreibung

valid_ok

Die Operation wurde erfolgreich ausgeführt.

validate_wf

Die Operation wurde mit Warnungen ausgeführt.

validate_bad

Die Operation ist fehlgeschlagen.

 

Zusätzlich dazu werden im Fenster "Meldungen" eventuell die folgenden Arten von Meldungen angezeigt: Informationen, Warnungen und Fehler.

 

Symbol

Beschreibung

_ic_validator_info

Kennzeichnet eine Informationsmeldung. Bei Informationsmeldungen wird die Mapping-Ausführung nicht gestoppt.

_ic_validator_warning

Kennzeichnet eine Warnmeldung. Bei Warnungen wird die Mapping-Ausführung nicht gestoppt. Sie werden z.B. generiert, wenn keine Verbindungen zu obligatorischen Input-Konnektoren erstellt wurden. In solchen Fällen wird dennoch eine Ausgabe für Komponenten mit gültigen Verbindungen generiert.

_ic_validator_error

Kennzeichnet einen Fehler. Bei einem Fehler schlägt die Mapping-Ausführung fehl und es wird keine Ausgabe generiert. Es kann auch keine Vorschau auf den XSLT- oder XQuery-Code generiert werden.

 

Andere Schaltflächen im Fenster "Meldungen" bieten die folgenden Möglichkeiten:

 

Symbol

Beschreibung

_ic_msg_filter

Filtert Meldungen nach ihrem Schweregrad (Informationsmeldungen, Fehler, Warnungen). Wählen Sie Alle aktivieren, um alle Schweregrade zu inkludieren (dies ist die Standardeinstellung).

 

Wählen Sie Alle deaktivieren, um alle Schweregrade aus dem Filter zu entfernen. In diesem Fall wird nur eine Meldung über den allgemeinen Ausführungs- oder Validierungsstatus angezeigt.

_ic_msg_next

Geht zur nächsten Zeile.

_ic_msg_prev

Geht zur vorherigen Zeile.

_ic_msg_clipboard

Kopiert die ausgewählte Zeile in die Zwischenablage.

_ic_msg_clipboard_children

Kopiert die ausgewählte Zeile einschließlich aller untergeordneten Zeilen in die Zwischenablage.

_ic_msg_clipboard_all

Kopiert den gesamten Inhalt des Fensters "Meldungen" in die Zwischenablage.

_ic_msg_find

Sucht im Fenster "Meldungen" nach einem bestimmten Text. Um optional nur nach Wörtern zu suchen, wählen Sie die Option Ganzes Wort. Um bei der Textsuche die Groß- und Kleinschreibung zu berücksichtigen, wählen Sie die Option GROSS/klein beachten.

_ic_msg_find_next

Sucht ab der aktuell ausgewählten Zeile bis zum Ende nach einem bestimmten Text.

_ic_msg_find_prev

Sucht ab der aktuell ausgewählten Zeile bis zum Anfang nach einem bestimmten Text.

_ic_msg_clear

Löscht die Meldungen im Fenster "Meldungen".

 

Wenn Sie gleichzeitig mit mehreren Mapping-Fenstern arbeiten, ist es sinnvoll, die Informationen, Warnungen und Fehlermeldungen für jedes Mapping auf einem eigenen Register anzuzeigen. Klicken Sie in diesem Fall auf die nummerierten Register auf der linken Seite des Fensters "Meldungen", bevor Sie ein Mapping ausführen oder validieren.

 

Applikationsstatusleiste

Die Applikationsstatusleiste wird am unteren Rand des Applikationsfensters angezeigt und zeigt Informationen zur Applikation an. Zu den nützlichsten Informationen zählen die Tooltipps, die angezeigt werden, wenn Sie die Maus über eine Symbolleisten-Schaltfläche platzieren. Wenn Sie die 64Bit-Version von MapForce verwenden, wird in der Statusleiste der Applikationsname mit dem Suffix (x64) angezeigt. Die 32-Bit-Version hat kein Suffix.

© 2015-2021 Altova GmbH