Einrichten eines Datenbankprojekts

www.altova.com Dieses Kapitel drucken Vorherige Seite Eine Ebene nach oben Nächste Seite

Startseite >  Tutorials > Datenbank "ZooDB" >

Einrichten eines Datenbankprojekts

Alle für Ihre Arbeit mit Datenbankprojekten benötigten Objekte/Dateien werden in Projektdateien organisiert. Sie können in einer Projektdatei die folgenden Elemente speichern:

 

Datenbankverbindungen
SQL Scripts
SQL-Vorlagen
Design-Dateien
Datenbankdatenvergleichsdateien
Datenbankschemavergleichsdateien
häufig verwendete Datenbankobjekte

 

Ziel

In diesem Abschnitt des Tutorials erfahren Sie, wie man ein Projekt in DatabaseSpy erstellt und eine Verbindung zu einer Datenbank herstellt.  Es werden die folgenden Schritte beschrieben:

 

Erstellen eines neuen Projekts und Hinzufügen einer Datenquellenverbindung
Hinzufügen von SQL-Dateien
Ändern des Projektnamens
Definieren der Projektstartoptionen

 

In diesem Abschnitt verwendete Befehle

Symbol

Befehlsname

Beschreibung

ic_quick-connect

Verbindung zu Datenbank herstellen

Dieser Befehl befindet sich in der Standard-Symbolleiste im Menü Datei. Klicken Sie auf diesen Befehl, um das Dialogfeld Datenquelle hinzufügen zu öffnen, in dem Sie eine Verbindung zu jeder beliebigen von DatabaseSpy unterstützten Datenbank herstellen können.

ic_add_sql_file

Dateien zum Projekt hinzufügen

Dieser Befehl befindet sich in der Symbolleiste des Projektfensters. Klicken Sie  auf diesen Befehl, um das Dialogfeld "Öffnen" zu öffnen, in dem Sie die Dateien, die zu Ihrem Datenbankprojekt hinzugefügt und darin gespeichert werden sollen, auswählen können.

ic_save_project

Projekt speichern

Dieser Befehl befindet sich in der Symbolleiste des Projektfensters. Alternativ dazu können Sie auch die Menüoption Datei | Projekt speichern unter... wählen oder Strg+S.drücken.  Klicken Sie auf diesen Befehl, um ein vorhandenes Projekt unter seinem Projektnamen zu speichern oder um einen Namen bzw. Pfad für ein neues Projekt zu speichern.

ic_show-design-options

Optionen anzeigen

Dieser Befehl befindet sich im Menü Extras. Klicken Sie auf den Befehl, um das Dialogfeld "Optionen" zu öffnen, in welchem Sie die Projektstartoptionen definieren können.

 


© 2019 Altova GmbH