Globale SQL-Anweisungen

www.altova.com Dieses Kapitel drucken Vorherige Seite Eine Ebene nach oben Nächste Seite

Startseite >  Globale Altova-Ressourcen > Verwendung globaler Ressourcen >

Globale SQL-Anweisungen

SQL-Anweisungen, die als *-SQL gespeichert wurden, können in DatabaseSpy als globale Ressourcen vom Typ Datei verwendet werden. Wenn Sie, zum Beispiel, eine Entwicklungs- und eine Produktionsdatenbank mit unterschiedlichen Namen und/oder Speicherorten verwenden, würden Sie zwei verschiedene SQL-Anweisungen benötigen, um die derzeit aktive Datenbank abzufragen. Indem Sie diese SQL-Anweisungen als globale Ressourcen definieren, können Sie nicht nur mit einem Mausklick zwischen den beiden Datenbanken umschalten, sondern bekommen auch gleich die zugehörige SQL-Anweisung im SQL Editor angezeigt. Sie müssen nur noch den SQL Editor mit der Datenquelle synchronisieren und die Abfrage ausführen.

 

Anzeigen von globalen Ressourcen vom Typ Datei im SQL Editor

Globale Ressourcen vom Typ Datei können im SQL Editor wie jede andere SQL-Datei angezeigt, bearbeitet und ausgeführt werden. Wenn Sie im Dialogfeld "Globale Ressourcen verwalten" auf die Schaltfläche Ansicht klicken, wird die Datei im Hintergrund im SQL Editor angezeigt, während das Dialogfeld "Globale Ressourcen verwalten" geöffnet bleibt, damit Sie die globale Ressource erforderlichenfalls bearbeiten oder löschen können.

dlg_glob-res-view-SQL

Alternativ können Sie auch das Menü Datei verwenden, um eine globale Ressource zu öffnen.

 

So zeigen Sie eine globale Ressource vom Typ Datei im SQL Editor an:

1.Wählen Sie die Menüoption Datei | Globale Ressource öffnen..., um das Dialogfeld "Globale Ressource wählen" anzuzeigen.
2.Wählen Sie unter dem Verzeichnis Dateien eine globale Ressource vom Typ Datei und klicken Sie auf OK. Die Datei wird unter ihrem Alias-Namen in einem neuen SQL Editor-Fenster angezeigt.

 

Wählen Sie alternativ die folgende Methode:

 

1.Wählen Sie die Menüoption Extras | Globale Ressourcen... oder klicken Sie auf die Symbolleistenschaltfläche Globale Ressourcen verwalten ic_manage-global-resources, um das Dialogfeld "Globale Ressourcen verwalten" zu öffnen.
2.Wählen Sie im Verzeichnis Dateien den Alias-Namen der SQL-Datei, die Sie anzeigen wollen, und klicken Sie auf die Schaltfläche Ansicht.
3.Klicken Sie auf Abbrechen, um das Dialogfeld "Globale Ressourcen verwalten" zu schließen.

 


© 2019 Altova GmbH