Öffnen, Speichern und Schließen von SQL-Dateien

www.altova.com Dieses Kapitel drucken Vorherige Seite Eine Ebene nach oben Nächste Seite

Startseite >  Arbeiten mit SQL >

Öffnen, Speichern und Schließen von SQL-Dateien

Jede im Dateisystem gespeicherte Datei kann über das Menü Datei | Öffnen (Strg+O) geöffnet werden und wird unter ihrem Dateinamen in einem neuen SQL Editor-Fenster angezeigt.

 

sql_animalType-queries

 

Wenn eine SQL-Datei, die bereits zum Projekt hinzugefügt wurde, kann sie über das Projektfenster geöffnet werden und wird unter ihrem Dateinamen in einem neuen SQL Editor-Fenster angezeigt. Eine Datei, die zu den Globalen Ressourcen hinzugefügt worden ist, kann über den Menübefehl Datei | Öffnen | Globale Ressource öffnen... geöffnet werden und wird unter ihrem Alias-Namen in einem neuen SQL Editor-Fenster angezeigt.

 

So öffnen Sie eine SQL-Datei:

Wählen Sie eine der folgenden Methoden:

 

Wählen Sie die Menüoption Datei | Öffnen | Datei öffnen... oder drücken Sie Strg+O. Daraufhin wird das Standard-Windows-Dialogfeld Öffnen angezeigt. Wählen Sie eine SQL (*.sql)-Datei aus und klicken Sie auf Öffnen.
Wählen Sie im Projektfenster im Ordner SQL eine der folgenden Methoden:

 

Wähen Sie eine SQL-Datei aus und doppelklicken Sie auf den Dateinamen.
Klicken Sie mit der rechten Maustaste auf die Datei und wählen Sie im Kontextmenü den Befehl Öffnen.

 

Die SQL-Datei wird in einem neuen SQL Editor-Fenster angezeigt.

 

So öffnen Sie eine globale Ressource:

Wählen Sie die Menüoption Datei | Öffnen | Globale Ressource öffnen..., um das Dialogfeld Globale Ressource wählen anzuzeigen und wählen Sie eine der folgenden Methoden:

 

Wählen Sie unter dem Verzeichnis Dateien eine globale Ressource vom Typ Datei und klicken Sie auf OK. Die Datei wird unter ihrem Alias-Namen in einem neuen SQL Editor-Fenster angezeigt.
Wählen Sie unter dem Verzeichnis Ordner eine globale Ressource vom Typ Ordner und klicken Sie auf OK. Das Standard-Windows-Dialogfeld Öffnen erscheint und zeigt den Inhalt des Ordners an, der für die aktive Konfiguration definiert ist. Wählen Sie eine Datei und klicken Sie auf Öffnen. Die Datei wird unter ihrem Dateinamen in einem neuen SQL Editor-Fenster angezeigt.

 

Wählen Sie alternativ die folgende Methode:

 

1.Wählen Sie die Menüoption Extras | Globale Ressourcen oder klicken Sie auf die Schaltfläche Globale Ressourcen verwalten ic_manage-global-resources in der Symbolleiste Globale Ressourcen.
2.Klicken Sie unter dem Verzeichnis Dateien auf den Alias-Namen der SQL-Datei, die Sie öffnen möchten.

 

gr_tree-files

 

3.Klicken Sie auf die Schaltfläche Anzeigen. Die Datei wird mit der Konfiguration geöffnet, die im Dropdown-Listenfeld der Symbolleiste Globale Ressourcen ausgewählt ist. Wenn die gewählte Konfiguration nicht anwendbar ist, wird die SQL-Datei mit der Standardkonfiguration Default geöffnet.

 

Neu parsen

Es kann vorkommen, dass ein Script Parsing-Fehler aufweist, wenn es erstmals im SQL Editor angezeigt wird. Wenn, zum Beispiel, die Ausführungsblöcke nicht korrekt gesetzt sind, würde ein solches Script einen Fehler hervorrufen, wenn es ausgeführt wird. (Um die Ausführungsblöcke zu überprüfen, aktivieren Sie das Symbol Gruppierungen für Ausführung ic_show-groupings anzeigen.) Die Syntaxfärbung könnte ebenfalls nicht richtig angezeigt werden, wenn das Script erstmals geparst oder vom Benutzer bearbeitet wird. Zum Korrigieren solcher Fehler steht in der SQL Editor-Symbolleiste die Schaltfläche Gesamtes Dokument neu parsen ic_reparse zur Verfügung.

 

So korrigieren Sie ein SQL-Script mit Parsing-Fehlern:

Klicken Sie in der SQL Editor-Symbolleiste auf die Schaltfläche Gesamtes Dokument neu parsen ic_reparse.

 

Speichern und Schließen

In DatabaseSpy stehen verschiedene Optionen zum Speichern von SQL-Anweisungen bzw. zum Schließen von einem oder mehreren Fenstern im SQL Editor zur Verfügung:

 

Speichern: Speichert den Inhalt des aktiven Fensters in der Datei, aus der er beim Öffnen abgerufen wurde.
Speichern unter: Öffnet das bekannte Windows-Dialogfeld Speichern unter, in dem Sie den Namen und den Pfad der Datei angeben können, unter denen die aktive Datei gespeichert werden soll.
Alles speichern: Speichert alle Änderungen, die an geöffneten Dokumenten vorgenommen wurden.
Schließen: Schließt das aktive Fenster.
Alles schließen: Schließt alle geöffneten Fenster.
Alle inaktiven schließen: Schließt alle geöffneten Fenster bis auf das aktive.

 

Bei allen Befehlen zum Schließen erscheint, wenn die Datei geändert wurde (angezeigt durch einen Stern nach dem Dateinamen in der Titelleiste) zuerst ein Dialogfeld, in dem Sie gefragt werden, ob Sie die Datei speichern möchten.

 

Alle Befehle außer Alle inaktiven schließen stehen im Menü Datei zur Verfügung; alle Befehle, die nur ein bestimmtes Fenster betreffen, sind im Kontextmenü enthalten, das erscheint, wenn Sie mit der rechten Maustaste auf das Register des entsprechenden SQL Editor-Fensters klicken.

 

sql_tab-context

 

Zusätzlich zu den oben angeführten Menübefehlen können Sie auch das Tastaturkürzel Ctrl+S verwenden, um die aktive SQL-Datei zu speichern.

 

Speichern von SQL Scripts

Sie können alle in einem SQL Editor-Fenster angezeigten SQL-Anweisungen speichern und das Script später wieder verwenden. Wenn der Inhalt eines SQL Editor-Fensters bereits gespeichert wurde, wird der Name der Datei in der Titelleiste des SQL Editor-Fensters angezeigt. Nicht gespeicherte Dateien werden durch ein Sternchen rechts vom allgemeinen Titel in der Titelleiste gekennzeichnet.

 

Ein gespeichertes SQL-Scripts kann für alle Altova Anwendungen verfügbar gemacht werden, indem es als globale Ressource definiert wird. Globale Ressourcen können in allen Altova Anwendungen verwendet werden, die die gleiche XML-Datei für globale Ressourcen benutzen.

 

So speichern Sie den Inhalt eines SQL Editor-Fensters in einer Datei:

1.Wählen Sie eine der folgenden Methoden:

 

Klicken Sie mit der rechten Maustaste auf das entsprechende SQL Editor-Fenster und wählen Sie im Kontextmenü den Befehl Speichern....
Machen Sie das SQL Editor-Fenster, das Sie speichern möchten, zum aktiven Fenster und drücken Sie Strg+S.

 

2.Wenn Sie die Datei zum ersten Mal speichern, wählen Sie im Dialogfeld Speichern unter... einen Namen und Pfad für die Datei aus und klicken Sie auf Speichern.

 

So speichern Sie eine SQL-Datei unter einem neuen Namen:

1.Klicken Sie mit der rechten Maustaste auf das Register des entsprechenden SQL Editor-Fensters und wählen Sie im Kontextmenü den Befehl Speichern unter....
2.Wählen Sie im Dialogfeld Speichern unter... einen neuen Namen und Pfad für die Datei und klicken Sie auf Speichern.

© 2019 Altova GmbH