Differences with XMLSpy Standalone

www.altova.com Print this Topic Previous Page Up One Level Next page

Home >  User Guide and Reference > XMLSpy in Visual Studio >

Differences with XMLSpy Standalone

This section lists the ways in which the Visual Studio versions differ from the standalone versions of XMLSpy. The listing starts with features that are unsupported in the Visual Studio version, and continues with a listing of other ways in which the Visual Studio version differs from the standalone version.

 

Unsupported features in Visual Studio
Additional XMLSpy menus s in Visual Studio
Entry helpers in Visual Studio
Same functionality, different command
XMLSpy commands as Visual Studio commands

 

Unsupported features in Visual Studio

The following XMLSpy features are not available in Visual Studio:

 

The Scripting environment (Tools | XMLSpy Options | Scripting) is currently not supported.
Separate browser window (an option in the Tools | Options | View section) is not supported. This means the the Text View and Browser View are always in the same window.
The text state icons of Authentic View are not supported.
All Source Control functionality.
All comparison functionality (available in the Tools menu of the standalone version).

 

Additional XMLSpy menus in Visual Studio

The following commands are specific to XMLSpy in Visual Studio:

 

View | XMLSpy Tool Windows
View | XMLSpy View
XMLSpy (includes Global Resources menu items)
Tools | XMLSPY Options

 

Entry helpers (Tool windows in Visual Studio)

The entry helpers of XMLSpy are available as Tool windows in Visual Studio. The following points about them should be noted. (For a description of entry helpers and the XMLSpy GUI, see the section, Introduction.)

 

You can drag entry helper windows to any position in the development environment.
Right-clicking an entry helper tab allows you to further customize your interface. Entry helper configuration options are: dockable, hide, floating, and auto-hide.

 

Same functionality, different command

Some functionality of XMLSpy is available in Visual Studio under differently named commands. These are:

 

XMLSpy

Visual Studio

Functionality

File | Open | Switch to URL

File | Open | Website

Opens file from URL

Switch to URL | Save

File | Save XMLSpy File to URL

Saves file to URL

 

XMLSpy commands as Visual Studio commands

Some XMLSpy commands are present as Visual Studio commands in the Visual Studio GUI. These are:

 

Undo, Redo: These Visual Studio commands affect all actions in the Visual Studio development environment.
Projects: XMLSpy projects are handled as Visual Studio projects.
Customize Toolbars, Customize Commands: The Toolbars and Commands tabs (screenshot below) in the Customize dialog (Tools | Customize) contain both Visual Studio commands as well as XMLSpy commands.

net-cust-keyb

Views: In the View menu, the two commands, XMLSpy Tool Windows and XMLSpy View, contain options to toggle on entry helper windows and other sidebars, switch between the editing views, and toggle certain editing guides on and off.
XMLSpy Help: This XMLSpy menu appears as a submenu in Visual Studio's Help menu.

 


© 2019 Altova GmbH