Settings and Customization

www.altova.com Print this Topic Previous Page Up One Level Next page

Home >  User Guide and Reference > Interface and Environment > The Application Environment >

Settings and Customization

In XMLSpy, there are several settings and customization options that you can select. In this section, we point you to these options and also briefly discuss some aspects of XMLSpy menus. This section is organized into the following parts.

 

Settings
Customization
Menus

 

Settings

Several important XMLSpy settings are defined in different tabs in the Options dialog (screenshot below, accessed via the menu command Tools | Options). You should look through the various options to familiarize yourself with what's available.

 

tools_sett_file

 

Given below is a summary of the most important settings. For details, see the description of the Options dialog in the User Reference section.

 

File types and default views: In the File Types tab, you can add file types that XMLSpy will recognize. A file type is specified by a file extension. For each file type, you can then specify conformance to a particular standard (for example conformance to the DTD, XQuery, or JSON standard). This setting will switch on editing aids relevant to the standard selected for a particular file type. You can also specify in what XMLSpy view files of each file type should open (the default view for this file type).
File validation: In the File tab (screenshot above), you can specify whether files should be validated automatically on opening and/or saving. In the File Types tab (see previous bullet point), file validation can then be disabled for specific file types.
Editing features: In the Editing tab, you can specify how entry helpers should be organized, how new elements are generated, and whether auto-completion is enabled. Additional options are available for individual views in the View tab. In the Fonts tabs for various views, you can specify the font characteristics of individual node types in each of these views.
XSLT and FO Engines: In the XSL tab, you can specify that an external XSL engine be used for transformations made from within the GUI. You must also specify the location of the FO processor executable to be used for FO processing within XMLSpy. For more information, see the XSLT Processing section.
Encoding: Default encodings for XML and non-XML files are specified in the Encoding tab.

 

Customization

You can also customize various aspects of XMLSpy, including the appearance of the GUI. These customization options are available in the Customize dialog (screenshot below, accessed via the menu command Tools | Customize).

 

new_mnu_customize_commands

 

The various customization options are described in the User Reference section.

 

Menus

Menu commands are enabled/disabled depending upon three factors: (i) file type, (ii) active view, and (iii) current cursor location or current document status. For example:

 

File type: The command DTD/Schema | Include Another DTD is enabled only when the active file is a DTD. Similarly, commands in the WSDL menu will be enabled only when a WSDL file is active.
Active view: Most commands in the Schema Design menu will be active only when the active view is Schema View.
Current cursor location, document status: In Grid View, whether the command to add an attribute as a child node (XML | Add Child | Attribute) is enabled will depend on whether the selected item in Grid View is an element or not (current cursor location). When an XSLT document is active the Stop Debugger command will not be active till after a debugger session has been started (current document status).

 

Note also that you can customize menus (Tools | Options) as well as drag and reorganize them within the GUI (see Menu Bar, Toolbars, Status Bar).

 


© 2019 Altova GmbH