Menus and Toolbars

www.altova.com Print this Topic Previous Page Up One Level Next page

Home >  XMLSpy Tutorial > XMLSpy Interface >

Menus and Toolbars

In this section of the tutorial, you will quickly learn about the main features of the menus and toolbars of XMLSpy.

 

Menus

There are two menu bars: (i) a default menu that is displayed when no document is open, and (ii) the full XMLSpy application menu, which is displayed as soon as a document is open. Do the following:

 

1.Close all open documents with the menu command File | Close All. You will see the default menu.
2.Open the AddressFirst.xsd file by clicking its name from the list of most recently opened files located at the bottom of the File menu. When the file opens in Schema View, the menu will change to the full XMLSpy application menu.

 

 

The menus are organized primarily according to function, and a command in a menu is enabled only when it can be executed at the cursor point or for a selection in the current view of the active document. Do the following to understand the factors that determine whether a menu command is enabled or disabled:

 

1.Click the Schema Design menu. Notice that the Save Diagram, Configure View, and Zoom commands are disabled (screenshot below).

TutMenu01

2.Click in a blank space outside the menu to make the menu disappear. Then click the Display Diagram icon ic_component located to the left of the element component. This takes you to the Content Model View of Schema View (the second of Schema View's two views; the first is Schema Overview). If you check the Schema Design menu now, you will see that the Save Diagram, Configure View, and Zoom commands have been enabled. They are enabled only in the Content Model View of Schema View, not in the Schema Overview of Schema View, nor in any other view. Note also that only XML Schema files can be opened in Schema View.
3.An XML Schema file is also an XML file, so it is displayed as an XML file in Text View and Grid View, and all menu commands that apply to XML files will be enabled in these views. Compare commands in the Edit menu (whether they are enabled or not) in Schema View and Text View.
4.Next compare commands in the XML | Insert menu (enabled or disabled) in Text View and Grid View. The commands in this menu are enabled only in Grid View.

 

For descriptions of all the menu commands, see the User Reference section of the user documentation.

 

Toolbars

The display of toolbars varies according to the current view. The application's default settings provide the correct toolbars for each view and will be different for each view. However, you can customize toolbars in the Toolbars tab of the Customize dialog (Tools | Customize | Toolbars, screenshot below).

new_mnu_customize_toolb

Now, practise moving toolbars around the GUI. Click the handle of a toolbar and drag the toolbar to any desired location in the GUI. (The toolbar handle is indicated by the dotted vertical line at the left of each toolbar; see screenshot below.)

TutToolbar01

Try dragging a toolbar to the following locations: (i) another line in the toolbar area; (ii) left or right of another toolbar; (iii) the middle of the Main window; (iv) docked to the left or right side of the application window (for this to happen, the grab handle must be placed above the left or right border of the application window).

 

After you have finished, close the file AddressFirst.xsd.

 


© 2019 Altova GmbH