Accessing Common Menus and Functions

www.altova.com Print this Topic Previous Page Up One Level Next page

Home >  MapForce Plug-in for Eclipse >

Accessing Common Menus and Functions

In Eclipse, you can access most MapForce functionality from the same menus as in the standalone version, except for some Eclipse-specific variations which are listed below. This is the default setup; however, you can further customize the interface preferences from Eclipse, if desired (see The MapForce Perspective).

 

Note:In Eclipse, some MapForce menu groups or commands are disabled (or not available) if the context is not relevant. For example, the Insert menu becomes available only when a mapping design file (.mfd) is active in Eclipse.

 

For information about the MapForce standard menus, see Menu Reference.

 

General MapForce commands

In the standalone edition of MapForce, the commands applicable to mapping design files (such as Validate, Deploy to FlowForce Server, Generate Code, and others) are available in the File menu. In Eclipse, these commands are available in the MapForce menu, or in the MapForce toolbar. Note that the commands for opening or saving files (including MapForce project files) are available in the File menu of Eclipse.

gui_mf_eclipse_toolbar

The MapForce toolbar in Eclipse

The gui_mf_eclipse_help toolbar button opens the MapForce help file.

 

The toolbar_mapforce toolbar button displays commands specific to MapForce files. When you expand this button, the available commands depend on the kind of file currently active in the Eclipse editor. For example, the commands specific to mapping design (.mfd) files are available when such a file is active (in focus) in the Eclipse editor.

 

Global Resources

To access or manage Global Resources, do one of the following:

 

Click to expand the MapForce toolbar_mapforce toolbar button, and then click Global Resources.
On the MapForce menu, click Global Resources.

 

MapForce Projects

In the standard edition of MapForce, the Project menu contains various commands applicable to mapping project (.mfp) files. In Eclipse, these commands exist as follows:

 

The commands to open or save a project are available from the Eclipse File menu.
Other project-specific commands are available as context commands. To display the context commands, create or open a MapForce project (.mfp) file in Eclipse, and then right-click the project.

gui_mfp_eclipse

Note that, in addition to standard MapForce projects (.mfp), in Eclipse you can also create projects of type "MapForce/Eclipse". Such projects have a dual nature, and can be configured for automatic build and generation of MapForce code. See Working with Mappings and Projects.

 

MapForce Options

MapForce options are available from the Window | Preferences menu. On the Preferences dialog box, select MapForce, and then click Open MapForce Options Dialog.

mf_eclipse_options_zoom25

Preferences dialog box

 

Libraries window

In Eclipse, the MapForce Libraries window is available as a view. This view is by default located to the left of the main editor window. (All MapForce-related views become visible in Eclipse interface when the MapForce perspective is switched on, see also The MapForce Perspective).

 

MapForce plug-in version

To see the currently installed version of the MapForce Plug-in for Eclipse, select the Eclipse menu option Help | About Eclipse. Then select the MapForce icon.

 

Help and Support

MapForce Help, Support Center, Check for Updates and About menus are available in the Help | MapForce Help menu of Eclipse.


© 2019 Altova GmbH