Please enable JavaScript to view this site.

Altova MapForce 2020 Enterprise Edition

When MapForce plug-in for Visual Studio is enabled, you can access common menus and functions as shown below. This is the default setup; however, you can customize menus and toolbars from the Tools | Customize menu of Visual Studio.

 

Global Resources

MapForce Global Resources are available in the MapForce | Manage Global Resources menu of Visual Studio.

 

Note:In Visual Studio 2019, the corresponding menu is Extensions | MapForce | Manage Global Resources.

 

Mapping debugging

After you have opened a mapping design file, the mapping debugging commands are available in the MapForce | Debug menu and in the Debug toolbar. You can also initiate debugging from the keyboard shortcuts (see Debugger Commands).

 

MapForce options

MapForce options are available in the Tools | MapForce Options menu of Visual Studio.

 

Mapping pane customization

When there is a MapForce mapping opened in the main pane of Visual Studio, the View | MapForce menu becomes available. It includes the same options as the View menu of the standalone version of MapForce.

 

Libraries window

If the MapForce Libraries window is not visible in Visual Studio, you can enable it from the View | MapForce | Libraries Window menu (this menu becomes available in Visual Studio when a mapping file is open). Once the Libraries window is enabled, you can doc it to a particular position in the interface, like any other dockable component of Visual Studio.

mf_vs_integration06

The Libraries Window (Visual Studio 2017 with MapForce Enterprise edition plug-in)

 

Toolbar and commands customization

You can customize MapForce menus and toolbars from the Tools | Customize menu of Visual Studio.

 

Help and Support

MapForce Help, Support Center, Check for Updates and About menus are available in the Help | MapForce Help menu of Visual Studio.

© 2020 Altova GmbH