Toolbar icons

www.altova.com Print this Topic Previous Page Up One Level Next page

Home >  User Reference >

Toolbar icons

Icons in the toolbar are shortcuts for various commands, most of which are also available as menu commands. You can toggle the display of any group of icons in the toolbar on or off using the Toolbars tab of the Customize dialog (Tools | Customize). In the GUI, you can move a toolbar by dragging its handle to the desired location.

 

The available toolbars are depicted below. Clicking the individual toolbar icons will display the description of the corresponding command.

 

The Standard toolbar contains shortcuts for file commands and common editing commands that occur in the File, Edit, and XML menus.

Toggle 2-way/3-way comparisonCompare Files 3-wayCompare XML SchemasCompare Word FilesCompare Database SchemaCompare Database DataValidate FileCheck Well-formednessPrintReplaceFind NextFindRedoUndoErasePasteCopyCutCompare DirectoriesCompare Files__tb_standard-ent

The Comparison Mode toolbar enables you to select the comparison mode for files and directories. This group of commands is available in the Diff and Merge menu.

Show files in ZIP archivesQuick ComparisonCompare as Text or XMLCompare as BinaryCompare as XMLCompare as Texttb_comparison-mode

The Database Data Comparison Mode toolbar enables you to select the comparison mode for database data. This group of commands is available in the Diff and Merge menu.

XML ComparisonNative ComparisonString Comparisontb_db-data-comp-mode

The Diff and Merge toolbar enables you to start comparisons, navigate through differences between files, merge differences, and set application and comparison options. All these commands are available in the Diff and Merge menu and in the Tools menu.

tb_diff-and-merge

The Directory Content toolbar enables you to configure the display of Directory Comparison windows. Note that—except for the directory synchronization commands, which are included in the Diff and Merge menu—none of these commands are available as menu commands . Each of these commands applies to the active directory comparison only.

Select FilterEdit FilterShow/HideInclude Sub-directoriesExpand/CollapseSynchronize SelectedSynchronizetb_directory-content

The Word Comparison toolbar enables you to configure the display of Word Comparison windows. Note that none of these commands are available as menu commands.

tb_word

The Database Data Comparison Result toolbar enables you to configure the display of Database Data Comparison Result windows. Note that these commands are available only as context menu commands. Each of these commands applies to the active database data comparison result only.

tb_db-data-comp-result

The Grid toolbar is enabled in Grid View in File Comparison windows, and most of these commands are available in the Grid View menu. With the Grid Group commands, you can make structural editing changes and modify the Grid View of your XML document. Grid View is not available for non-XML or non-well-formed documents; that is, for the Grid View of a document to be displayed, the document must be an XML document and be well-formed.

Move RightMove LeftDescending SortAscending SortAppend RowInsert RowDisplay as Tabletb_grid

The following icons are not included in the Grid View menu:

 

ic_expand-all-selected Expand all selected: In Grid View, this command expands one or more selected nodes in Grid View.
ic_collapse-all-selected Collapse all selected: In Grid View, this command collapses the selected nodes.
ic_fully-expand-all-selected Fully expand all selected: In Grid View, this command expands all selected nodes and their descendant nodes.
ic_collapse-unselected Collapse unselected: In Grid View, this command collapses all selected nodes and their descendant nodes.
ic_optimal-widths Optimal widths: In Grid View, this command sets columns to optimal widths.

 

The Text toolbar enables you to configure the display and navigation features of Text View. Some of these commands apply to the selected file only (that is, the file in which the cursor is). Other commands apply to all open files and subsequently opened files. All these commands are available as Text View menu commands.

Text View SettingsToggle All FoldsRemove All BookmarksPrevious BookmarkNext BookmarkInsert/Remove BookmarkGo to Line/CharPretty PrintWord Wraptb_text-view

Icons in the Grid Edit Group are used for editing in Grid View. These commands are fully described in the Grid View Menu section. Please note that this toolbar is deactivated by default, you have to activate the respective check box in the Toolbars tab of the Tools | Customize dialog box to view it.

Add Child NotationInsert NotationAppend NotationAdd Child EntityInsert EntityAppend EntityAdd Child ATTLISTInsert ATTLISTAppent ATTLISTAdd Child Doctype ElementInsert Doctype ElementAppend Doctype ElementAdd Child External IDInsert External IDAppend External IDAdd Child DoctypeInsert DoctypeAppend DoctypeAdd Child Processing InstructionInsert Processing InstructionAppend Processing InstructionAdd Child XML DeclarationInsert XML DeclarationAppend XML DeclarationAdd Child CommentInsert CommentAppend CommentAdd Child CDataInsert CDataAppend CDataAdd Child TextInsert TextAppend TextAdd Child ElementInsert ElementAppend ElementAdd Child AttributeInsert AttributeAppend Attributetb_grid-edit

The 3-way Comparison toolbar contains commands applicable to three-way comparisons, see Navigating and Merging Three-Way Differences.

dd_3way_toolbar


© 2019 Altova GmbH