Main Window

www.altova.com Print this Topic Previous Page Up One Level Next page

Home >  User Guide and Reference > Interface and Environment > The Graphical User Interface (GUI) >

Main Window

The Main Window (screenshot below) is where you view and edit documents.

 

MainWindow

 

Files in the Main Window

 

Any number of files can be opened and edited at once.
Each open document has its own window and a tab (containing the document's file name) at the bottom of the Main Window. To make an open document active, click its tab.
If several files are open, some document tabs might not be visible for lack of space in the document tabs bar. Document tabs can be brought into view by: (i) using the scroll buttons at the right of the document tab bar, or (ii) selecting the required document from the list at the bottom of the Window menu.
When the active document is maximized, its Minimize, Restore, and Close buttons are located at the right side of the Menu Bar. When a document is cascaded, tiled, or minimized, the Maximize, Restore, and Close buttons are located in the title bar of the document window.
When you maximize one file, all open files are maximized.
Open files can be cascaded or tiled using commands in the Window menu.
You can also activate open files in the sequence in which they were opened by using Ctrl+Tab or Ctrl+F6.
Right-clicking a document tab opens a context-menu with a selection of File commands, such as Print and Close.

 

Views in the Main Window

The active document can be displayed and edited in multiple views. The available views are displayed in a bar above the document tabs (see illustration above), and the active view is highlighted. A view is selected by clicking the required view button or by using the commands in the View menu.

 

The available views are either editing or browser views:

 

Authentic View: For editing XML documents that are based on StyleVision Power Stylesheets in a graphical interface.
Browser View: An integrated browser view that supports both CSS and XSL stylesheets.

 

Note:The default view for individual file extensions can be customized in the Tools | Options dialog: in the Default View pane of the File Types tab.

 


© 2019 Altova GmbH